Pre-defined Queries

Custom Query (12076 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (58 - 60 of 12076)

Ticket Resolution Summary Owner Reporter
#14656 fixed x86_gcc2 build: don't know how to make haiku_loader.efi kallisti5 korli
Description

see https://build.haiku-os.org/buildbot/#/builders/35/builds/66/steps/27/logs/stdio

haiku_loader.efi probably shouldn't be added to the default list of targets on x86.

#10042 fixed x86 DEBUG builds are failing since PM merge pdziepak umccullough
Description

Since the package management merge, the x86 DEBUG builds are failing. The last successful DEBUG=1 build that our buildslaves were able to perform was with hrev46110.

Buildbot slaves uses the following to test the DEBUG builds:

jam -q -sDEBUG=1 -sHAIKU_IMAGE_NAME=haiku-debug.image -sHAIKU_IMAGE_SIZE=1524 @image

There appears to be a linking issue with addattr, as seen at the bottom of the buildbot output:

http://mmadia.dyndns.org:8010/builders/x86-debug-any-host/builds/1923/steps/%5Bx86gcc2%5D-debug/logs/stdio

MergeObjectFromObjects1 /work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/x86_64/debug_1/build/libbe/support/support_kit.o 
Link /work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/lib/libbe_build.so 
Chmod1 /work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/lib/libbe_build.so 
Link /work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/x86_64/debug_1/tools/addattr/addattr 
/work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/lib/libbe_build.so: undefined reference to `_get_thread_info'
collect2: ld returned 1 exit status

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/lib ; /work/haiku/slave2/haiku/build/scripts/rm_attrs /work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/x86_64/release/tools/rm_attrs -f "/work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/x86_64/debug_1/tools/addattr/addattr"
cc -Xlinker --no-as-needed -lm -o "/work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/x86_64/debug_1/tools/addattr/addattr"   "/work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/x86_64/debug_1/tools/addattr/main.o" "/work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/x86_64/debug_1/tools/addattr/addAttr.o" \
"/work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/x86_64/debug_1/build/libroot/libroot_build_function_remapper.a" "/work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/lib/libroot_build.so" "/work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/lib/libbe_build.so" -lstdc++ -lsupc++  \


...failed Link /work/haiku/slave2/x86-debug-any-host/generated.x86gcc2-debug/objects/linux/x86_64/debug_1/tools/addattr/addattr ...
#12077 no change required x86 build won't install, etc nobody haiqu
Description

Just built a pure x86 cross-compiler today and - for shits and giggles - decided to try building the x86 version of Haiku.

It almost worked. The installer tells me there's an error of "No Error" when clicking install. Booting from the USB stick and running it from there I got as far as a desktop, but it had no logo and the Tracker dropboxes weren't available so I couldn't run any of the standard programs or demos.

Since this is my first non-hybrid build I'm unsure whether this is all normal at the current stage of development, or whether it's wrong.

Note: See TracQuery for help on using queries.