Opened 7 years ago

Last modified 6 months ago

#10162 assigned bug

WIFI doesn't automatically connect

Reported by: Giova84 Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/net_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description (last modified by diver)

I have an atheros wifi card, WPA2 auth method. Every time that I boot Haiku, also if i choose to store the details, i have to manually select my SSID.

syslog attached.


Attachments (1)

syslog (17.9 KB ) - added by Giova84 7 years ago.

Download all attachments as: .zip

Change History (10)

by Giova84, 7 years ago

Attachment: syslog added

comment:1 by diver, 7 years ago

Component: ServersServers/keystore_server
Description: modified (diff)
Owner: changed from nobody to mmlr
Platform: x86All

comment:2 by diver, 7 years ago

Do you need to enter your password after connecting to your SSID?

comment:3 by Giova84, 7 years ago

No, i don't need to enter again my password. So the keystore_server shouldn't be the culprit.

comment:4 by Giova84, 7 years ago

I have momentarily solved with the following workaround: Inside UserBootScript i have added

ifconfig /dev/net/atheroswifi/0 join MYSSID

But is only a temporary workaround :-)

comment:5 by diver, 7 years ago

Component: Servers/keystore_serverServers/net_server
Owner: changed from mmlr to axeld

comment:6 by miqlas, 5 years ago

I have the same problem with my Atheros WLAN adapter, the network also WPA2.

Haiku (recent nightly gcc2h) does not ask for password, it just does not connect automatically, so i need to go to the right click menu of NetworkStatus replicant, and select my SSID, then it connectin without problem.

I will try the UserBootScript workaround, but it would be better to locate and eliminate this bug for the new users.

Last edited 5 years ago by miqlas (previous) (diff)

comment:7 by humdinger, 5 years ago

I does work for my iprowifi4695 after setting the WLAN in the Network preferences. Have you tried that?

comment:8 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:9 by X512, 6 months ago

Still present in hrev53639.

WiFi adapter is [168c:002b] Atheros AR9285.

Note: See TracTickets for help on using tickets.