Opened 6 years ago

Closed 6 years ago

#10285 closed bug (duplicate)

Incorrect file sizes in NFS mounts

Reported by: kallisti5 Owned by: mmu_man
Priority: normal Milestone: R1
Component: File Systems/NFS Version: R1/Development
Keywords: Cc:
Blocked By: #9787 Blocking:
Has a Patch: no Platform: All

Description

NFS mount has incorrect file sizes. (see screenshot attached)

syslog:

KERN: nfs: mount(8, <NULL>, 00000000)
KERN: nfs: nfs_params: nfs:192.168.1.120:/volume1/video,uid=0,gid=0,hostname=shredder
KERN: nfs:ip!
KERN: IP:192.168.KERN: 1.KERN: 120
KERN: nfs:hn!
KERN: nfs:uid!
KERN: nfs:gid!
KERN: nfs: ip:c0a80178 server:'192.168.1.120' export:'/volume1/video' hostname:'shredder' uid=0 gid=0 
KERN: nfs: mountd at 7801a8c0:892
KERN: nfs: nfsd at 7801a8c0:2049

Some sizes are negative, some sizes are just wrong by a few GB.

gcc2h hrev46506

Attachments (1)

screenshot9.png (45.5 KB ) - added by kallisti5 6 years ago.
screenshot of tracker

Download all attachments as: .zip

Change History (5)

by kallisti5, 6 years ago

Attachment: screenshot9.png added

screenshot of tracker

comment:1 by kallisti5, 6 years ago

The output of ls -lah comfirms the same result coming back with numbers like:

-rwxrwxrwx 1 1025 users   16E 2013-01-10 01:44

Pretty sure I don't have a 16E file on my 1.9TB nas :-)

comment:2 by joy, 6 years ago

This is true when using the old NFS(mount_nfs 10.10.10.10:/share/NFS /NFS 500 100) For me it is just files over 2GB that is a problem, When they show an error you cant copy them to your local Haiku. It has been like the for the past 2 years.

Works fine with NFS4 (mount -t nfs4 -p "10.10.10.10:/NFS" /NFS)

I am running QNAP Nas OS 4.x with Linux kernel version 2.6.33.2

Version 0, edited 6 years ago by joy (next)

comment:3 by luroh, 6 years ago

Looks like a possible duplicate of #9787, which also contains a patch or two.

comment:4 by diver, 6 years ago

Blocked By: 9787 added
Resolution: duplicate
Status: newclosed

Indeed.

Note: See TracTickets for help on using tickets.