Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10319 closed bug (duplicate)

WebPositive fails rendering border-radius and bleeds the border color on the background.

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #10214 Blocking:
Has a Patch: no Platform: All

Description

Installed hrev46543 gcc2 hybrid. Open Webpositive to Haiku Project home page. Selecting tabs for "Source Activity", "Ticket Updates" etc causes "Blog-O-Sphere" and "Forums" area on left side of page to shade grey. When mouse pointer is passed over these shaded areas, text is unshaded. Selecting another tab will cause shading again.

Attachments (3)

screenshot2.png (219.6 KB ) - added by vidrep 6 years ago.
screenshot3.png (211.1 KB ) - added by vidrep 6 years ago.
screenshot4.png (214.2 KB ) - added by vidrep 6 years ago.

Download all attachments as: .zip

Change History (11)

by vidrep, 6 years ago

Attachment: screenshot2.png added

by vidrep, 6 years ago

Attachment: screenshot3.png added

by vidrep, 6 years ago

Attachment: screenshot4.png added

comment:1 by vidrep, 6 years ago

Attached screenshots showing the issue I described earlier. These were taken using hrev46651 x86 gcc2. Note how selecting the different tabs causes the boxed areas on the left to shade. When the mouse is passed over this shaded area, the lines unshade.

comment:2 by waddlesplash, 6 years ago

Probably the border-color bleeding again.

comment:3 by anevilyak, 6 years ago

Component: - GeneralApplications/WebPositive
Owner: changed from nobody to pulkomandy

comment:4 by vidrep, 6 years ago

I also noticed that sometimes the text color in the shadad area changed from blue to black.

comment:5 by pulkomandy, 6 years ago

Yes, this is the same border color bleeding. Simple page showing the problem: http://pulkomandy.tk/drop/testcase.html

This happens when there is a border-radius, because of the way WebKit tries to render that and the lack of proper clipping in BView.

comment:6 by pulkomandy, 6 years ago

Summary: hrev46543 gcc2 nightly Webpositive page renderingWebPositive fails rendering border-radius and bleeds the border color on the background.

comment:7 by pulkomandy, 6 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #10214.

comment:8 by diver, 6 years ago

Blocked By: 10214 added
Note: See TracTickets for help on using tickets.