Opened 5 years ago

Closed 5 years ago

Last modified 11 months ago

#10536 closed bug (fixed)

Radeon drivers broken hrev46860

Reported by: vidrep Owned by: kallisti5
Priority: high Milestone: R1/beta1
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: #10614 Blocking:
Has a Patch: no Platform: All

Description

Installed hrev46860 32 bit and 64 bit to hard drive partitions Intel Extreme driver working with both builds ATI Radeon HD 3470 DVI - 32 bit no signal

  • 64 bit KDL on boot

ATI Radeon HD 3450 VGA - 32 bit no signal

  • 64 bit no signal

Both video cards confirmed to work correctly on a4.1 using radeon drivers from dev build dated 2012/11/14.

Attachments (6)

listdev1_HD3470_DVI (3.0 KB) - added by vidrep 5 years ago.
listdev2_HD3450_VGA (3.1 KB) - added by vidrep 5 years ago.
syslog_dev (488.9 KB) - added by vidrep 5 years ago.
syslog_x86_64 (354.5 KB) - added by vidrep 5 years ago.
IMG_0114.JPG (3.2 MB) - added by vidrep 5 years ago.
syslog_HD3000 (118.4 KB) - added by diger 5 years ago.

Change History (27)

Changed 5 years ago by vidrep

Attachment: listdev1_HD3470_DVI added

Changed 5 years ago by vidrep

Attachment: listdev2_HD3450_VGA added

Changed 5 years ago by vidrep

Attachment: syslog_dev added

Changed 5 years ago by vidrep

Attachment: syslog_x86_64 added

comment:1 Changed 5 years ago by kallisti5

Component: - GeneralDrivers/Graphics/radeon_hd
Owner: changed from nobody to kallisti5
Priority: normalhigh
Status: newassigned

"KERN: radeon_hd: connector_read_edid: invalid gpio 0 for connector 0"

I reworked the GPIO pins recently... looks like something got messed up somewhere. I'll take a look at this one asap.

comment:2 Changed 5 years ago by kallisti5

Milestone: R1R1/alpha5

comment:3 Changed 5 years ago by kallisti5

*should* be fixed as of hrev46862. My card didn't have more than 16 GPIO pins so I didn't notice this issue. Thanks for reporting!

Give it a test and let us know if this one is resolved.

comment:4 Changed 5 years ago by vidrep

I've attached the KDL from the 64 bit build

Changed 5 years ago by vidrep

Attachment: IMG_0114.JPG added

comment:5 Changed 5 years ago by vidrep

I have some NVidia cards to test as well. If there is a problem I'll open a new ticket for those.

comment:6 Changed 5 years ago by vidrep

Could this be somehow related to ticket #10535 - no warm boot?

comment:7 Changed 5 years ago by vidrep

Similar issue with hrev46885 only now there is a white screen. See possible duplicate ticket #10563.

comment:8 Changed 5 years ago by kallisti5

Please try again post-hrev46939

comment:9 Changed 5 years ago by vidrep

hrev46947_gcc2_hybrid Radeon HD2400 - DMS-59 - screen flashing between Desktop and black (working on alpha4.1) Radeon HD3450 - DVI & VGA - working Radeon HD3550 - DVI - working

hrev46947_x86_64 Radeon drivers not working - black screen, no signal with all cards.

After booting and blue screen appears, the time it takes to see the Desktop is taking on average 10 seconds longer than alpha 4.1. Maybe an unrelated problem?

Last edited 5 years ago by vidrep (previous) (diff)

comment:10 Changed 5 years ago by vidrep

The two Radeon cards described in the ticket (HD3450, HD3470) were working as of hrev46947. I'll open separate tickets for the non-working Radeon HD2400 and non-working 64 bit drivers described in last entry.

Last edited 5 years ago by vidrep (previous) (diff)

comment:11 Changed 5 years ago by luroh

Blocking: 7665 added

comment:12 Changed 5 years ago by kallisti5

It seems like Julian Harnath's recent work broke radeon_hd across a large number of cards. I'm working on tracking down the offending commit to revert it.

comment:13 Changed 5 years ago by jua

The commit in question would be hrev46988. The issues initially described in this bug ticket are older than my changes though, so these are definitely a separate problem.

I'm still quite sure that the change in hrev46988 is correct though. However it could be another bug that surfaced because of it. As said last night on IRC, it would be very useful to have a syslog of one of the machines where it broke because of hrev46988 so I could see what could be wrong.

comment:14 Changed 5 years ago by vidrep

See ticket #10614 for my syslog using hrev46950.

comment:15 Changed 5 years ago by jua

Ah, should have been more clear: the request for syslogs was to kallisti5 who said I broke it for many cards. Since your problem already occurs in hrev46950, it cannot have been introduced by my commit in hrev46988, that has to be something different.

comment:16 Changed 5 years ago by vidrep

Perhaps this ticket should be modified to read "64 bit Radeon Drivers Broken", since the 32 bit drivers appear to have been fixed some time ago (see ticket #10563).

comment:17 Changed 5 years ago by diger

hrev47098 x86_64, HD3000, DVI - black screen hrev47098 x86 - all ok

syslog

Last edited 5 years ago by diger (previous) (diff)

Changed 5 years ago by diger

Attachment: syslog_HD3000 added

comment:18 Changed 5 years ago by vidrep

The 32 bit Radeon drivers appear to work for some time now. It is the 64 bit drivers which continue to have a problem. This ticket should probably be closed and move the 64 bit driver issue to ticket #10614 which is 64 bit specific.

Last edited 5 years ago by vidrep (previous) (diff)

comment:19 Changed 5 years ago by pulkomandy

Blocked By: 10614 added
Resolution: fixed
Status: assignedclosed

comment:20 Changed 5 years ago by pulkomandy

Milestone: R1/alpha5R1/beta1

comment:21 Changed 11 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.