Opened 5 years ago

Closed 4 years ago

#11610 closed bug (fixed)

[Regression] sound stopped working in VirtualBox

Reported by: diver Owned by: pulkomandy
Priority: normal Milestone: R1/beta1
Component: Audio & Video Version: R1/Development
Keywords: Cc: degea@…
Blocked By: Blocking: #11388, #11666
Has a Patch: no Platform: All

Description

hrev48487.

I can't hear any audio in this revision. Booting to an older hrev48482 fixes it.

In hrev48482 sound starts only after playing mp3 file for 5-10 sec.

Change History (9)

comment:1 Changed 5 years ago by diver

Audio still works in VMware Fusion 7.1.0 with OpenSound driver in hrev48487.

comment:2 Changed 5 years ago by ttcoder

The libgame.so change in that rev range seems unlikely to be related..

Ideas:

  • might be corrupted settings; dsuden sees that fairly often: he deletes all media-kit related files in config/settings after shutting down media_server, then reboots to have them recreated to their normal out-of-the-box state, and things work again. Theoritically it should be possible to control/review them in MediaPrefs, but some are "hidden" in the OutputMapping tab, some might simply be more subtle corruption ..etc; we never got enough data on that bug to file a ticket on it..
  • other than that, might be the "butterfly effect" I see with #11497, where non-functioning sound can take 2 or 3 different forms and crawled up on me slowly with each pkgman update, until I couldn't get it to work any more..

comment:3 Changed 5 years ago by pulkomandy

Please try to get a backup of the corrupted settings files if possible, that could give us some information (and ideally provide a fresh/working settings file for the same machine). As we discussed with Diver on IRC, the changes in that revision range can't be related to the issue, so it's something else, either corrupted settings, or the buildbots doing strange things leading to disfunctional media kit.

comment:4 Changed 5 years ago by diver

Ok, and now sound is back in hrev48500. Hmm..

comment:5 Changed 5 years ago by ttcoder

Cc: degea@… added

Could be the 'butterfly effect' thing then (I mean sensitivity to tiny changes, including the ordering of package activations), rather than the settings. For comparison purposes, here's what I experienced in the month of november, before sound went out for good in december:

  • sound would be 'on' or 'off' randomly after pkgman up's
  • sound would come back when deleting the administrative/activated-packages and rebooting (i.e. no update involved, just resetting the already existing update); at least first time I tried, if not the second.
  • sound would go on or off if doing a pkgman up and then coming back to the previous hrev that was installed before (don't remember for sure how I accomplished that, since there is no officially sanctioned way of reverting that I know of; I think out of desperation I had preserved a full copy of one hrev's set of file and typed "pkgman install *.hpkg" within that folder or something :-P)

Anyway I've given pushing on that lead, now I'm hoping for the "worms armageddon" lead to be fruitful for Adrien instead ;-) ..

If you're seeing problems on recent/powerful hardware it gives more validity to pushing on this lead I suppose.. more than if it was just impacting old pentiums and core2 and stuff.

Version 0, edited 5 years ago by ttcoder (next)

comment:6 Changed 5 years ago by pulkomandy

Blocking: 11388 added

comment:7 Changed 5 years ago by luroh

Blocking: 11666 added

(In #11666) Removing #11650 as that problem is now well understood. Adding #11610.

comment:8 Changed 4 years ago by pulkomandy

Is this still a problem?

comment:9 Changed 4 years ago by diver

Resolution: fixed
Status: newclosed

Seems to be fixed now...

Note: See TracTickets for help on using tickets.