Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11707 closed bug (fixed)

no keyboard input since 48609

Reported by: luroh Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Drivers/Keyboard/PS2 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Not sure why but hrev48609 breaks all keyboard input in VMware and VirtualBox for me, pure gcc2.

Attachments (2)

com1.txt (85.0 KB ) - added by luroh 5 years ago.
serial log from vbox, hrev48613
com1_good.txt (66.8 KB ) - added by luroh 5 years ago.
serial log from a good boot, vbox, hrev48613

Download all attachments as: .zip

Change History (16)

comment:1 by waddlesplash, 5 years ago

Is this a homegrown version, or are you using one of the prebuilt nightlies?

comment:2 by bbjimmy, 5 years ago

Running on bare metal with a std gcc2h install, after updating to 48611 I got a similar issue. the keyboard does not reset whrn the desktop starts to show as it usually does. both the mouse and keyboaed are frozen. Even the Num-Lock and Caps-Lock keys are dead. no dafe-mode option will resolve it.

in reply to:  1 comment:3 by luroh, 5 years ago

Replying to waddlesplash:

Is this a homegrown version, or are you using one of the prebuilt nightlies?

Home brewed but squeaky-clean gcc2 @release-vmware.

comment:4 by luroh, 5 years ago

The problem is somewhat intermittent here. I just booted the same vmware image again and got keyboard back. It didn't survive a "warm" reboot however and is now gone again.

Last edited 5 years ago by luroh (previous) (diff)

by luroh, 5 years ago

Attachment: com1.txt added

serial log from vbox, hrev48613

comment:5 by luroh, 5 years ago

Serial log attached from a "bad" boot, with kernel_debugger 'threads' -> 'teams' -> 'bt #IDs'. The mouse was working during this time, but not keyboard. Additional note: restarting input_server sometimes fixes the problem (...and sometimes hangs the mouse as well).

Version 2, edited 5 years ago by luroh (previous) (next) (diff)

comment:6 by anevilyak, 5 years ago

One thing that's of interest from that output: The PS/2 keyboard watcher thread that should be there is missing entirely.

by luroh, 5 years ago

Attachment: com1_good.txt added

serial log from a good boot, vbox, hrev48613

comment:7 by anevilyak, 5 years ago

Component: - GeneralDrivers/Keyboard/PS2

Further note, the bad boot doesn't have any indicator that the PS2 keyboard was found at all, while the good boot does, so it'd appear this might be a timing problem on the part of the PS2 driver. That one hasn't changed in nearly a month though, so it's somewhat odd that it'd suddenly start displaying issues.

comment:8 by pulkomandy, 5 years ago

I get this problem on real hardware as well, for both keyboard and mouse.

comment:9 by pulkomandy, 5 years ago

I had a further look at the logs and the sources. The keyboard device is published ps2: devfs_publish_device input/keyboard/at/0, status = 0x00000000 but then we never get the ps2: keyboard found from keyboard_open. However we also don't get the "keyboard probing failed" message from there.

I rebuilt the ps/2 driver with tracing enabled, and it seems keyboard_open isn't called at all. ps/2 interrupts from the keyboard result in syslog messages: "input/keyboard/at/0 not enabled, data 0xa6 dropped".

Last edited 5 years ago by pulkomandy (previous) (diff)

comment:10 by taos, 5 years ago

Same problem on my laptop. Keyboard and touchpad (internal PS/2) still work on hrev48606 without problems, hrev48613 only accepts input by usb mouse/keyboard.

comment:11 by pulkomandy, 5 years ago

Possibly fixed in hrev48617?

comment:12 by luroh, 5 years ago

Sorry, still here in hrev48617.

comment:13 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev48619.

comment:14 by AlienSoldier, 5 years ago

hrev48675

I still get intermitent boot without the keyboard (PS/2) on real hardware. I kill the input server and have it back.

When not working, the input server pathmonitor tread is very active.

Note: See TracTickets for help on using tickets.