Opened 6 years ago

Closed 6 years ago

#12516 closed bug (invalid)

Cannot write anyboot image to USB stick

Reported by: HAL Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: cannot write anyboot usb Cc: HAL
Blocked By: Blocking:
Platform: All


I tried to write the latest x86_64 image to a USB stick. Although in the terminal output it seems to go through the motions, nothing is actually written.

  1. plug USB stick into slot unmounted.
  2. In teminal place command:
    dd if =/boot/home/haiku_install/haiku-nightly-anyboot.image of=/dev/disk/usb/0/0/raw bs =1M

Result: The terminal is busy for a few seconds as if writing the image. It says it has written the full 633Mb and finishes. When I try to mount it in DriveSetup, it says Error: invalid argument. When I replug the drive there is no mount option on the right click desktop menu. When I reboot and try to directly boot from the BIOS with the USB stick, computer boots to the linux grub menu instead. There has been no image written to the USB stick. I can format the USB stick with DriveSetup making sure I initialise with intel 32 partition map first: create FAT32 or BFS partition. i can mount these in DriveSetup and copy files to them. I was doing this in hrev49887 x86_64. I also tried with same results in one of the latest gcc2 nighties.

Change History (7)

comment:1 by humdinger, 6 years ago

Have you tried with different USB sticks? Under hrev49872 I just used the same dd command with a hrev49906 anyboot image and that resulted in a booting stick.

Version 0, edited 6 years ago by humdinger (next)

comment:2 by HAL, 6 years ago

I only have one USB stick. I might be able to get another tomorrow. How do I do a sync? I normally remove the drive after the output from the terminal finishes. I assume the USB stick remains unmounted since that is the state when writing the anyboot image. What is the command? Do you mean something like:

sync /dev/disk/usb/0/0/raw

comment:3 by humdinger, 6 years ago

A simple sync.

in reply to:  3 comment:4 by HAL, 6 years ago

Replying to humdinger:

A simple sync.

It is writing anyboot image now. I am not exactly sure if "sync" fixed it. I also re unzipped the anyboot image, incase there was corrupted unzip before.

comment:5 by humdinger, 6 years ago

Good! Should I close the ticket then?

comment:6 by HAL, 6 years ago

Yes, if it was a corrupted unzip or just needed "sync" doesn't matter.

comment:7 by humdinger, 6 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.