Opened 10 months ago

Last modified 3 weeks ago

#14298 reopened bug

[8086:3165] Intel iwm driver not loading for idualwifi7260

Reported by: mrentropy Owned by: waddlesplash
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/idualwifi7260 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Intel Wireless 3165 should be supported by the iwm driver. It currently fails on boot using 32-bit and 64-bit builds.

According to Waddlesplash, the issue is here:

KERN: [idualwifi7260] (iwm) fw chunk addr 0x800000 len 98304 failed to load

KERN: [idualwifi7260] (iwm) iwm_pcie_load_section: Could not load the [0] uCode section

KERN: [idualwifi7260] (iwm) iwm_start_fw: failed -2147483639

Attachments (6)

Syslog-iwm3165.zip (23.4 KB) - added by mrentropy 10 months ago.
Syslog contents of 32-bit build
syslog (194.3 KB) - added by mrentropy 10 months ago.
Syslog contents of 32-bit build
syslog.2 (432.2 KB) - added by mrentropy 4 months ago.
Syslog from hrev52730
syslog.3 (159.0 KB) - added by cb88 4 months ago.
hrev52750 iwm broken for me, wifi was working on beta1
syslog.4 (171.0 KB) - added by masaol 4 months ago.
hrev52792, x64
syslog-hrev53001 (200.1 KB) - added by mrentropy 2 months ago.
Syslog from hrev53001 by request

Download all attachments as: .zip

Change History (23)

Changed 10 months ago by mrentropy

Attachment: Syslog-iwm3165.zip added

Syslog contents of 32-bit build

comment:1 Changed 10 months ago by waddlesplash

Component: Network & Internet/WirelessDrivers/Network/idualwifi7260
Keywords: iwm driver wireless 3165 intel removed
Owner: changed from mmlr to waddlesplash

comment:2 Changed 10 months ago by waddlesplash

Please attach the syslog unzipped.

Changed 10 months ago by mrentropy

Attachment: syslog added

Syslog contents of 32-bit build

comment:3 Changed 10 months ago by waddlesplash

It appears the 3165 uses the "7265D" firmware: http://xref.plausible.coop/source/xref/haiku/src/add-ons/kernel/drivers/network/wlan/idualwifi7260/dev/iwm/if_iwm_7000.c#109

That's the exact same firmware my device uses, and it works, so I don't think that's the issue.

comment:4 Changed 5 months ago by waddlesplash

Please retest after hrev52722.

comment:5 Changed 5 months ago by kim1963

rev 52745

KERN: [idualwifi7260] (iwm) bus_alloc_resource(3, [16], 0x0, 0xffffffff, 0x1,0x2)

KERN: add_memory_type_range(2067, 0xa2100000, 0x2000, 0)

KERN: set MTRRs to:

KERN: mtrr: 0: base: 0x8a000000, size: 0x2000000, type: 0

KERN: mtrr: 1: base: 0xa0000000, size: 0x20000000, type: 0

KERN: mtrr: 2: base: 0xc0000000, size: 0x40000000, type: 0

KERN: mtrr: 3: base: 0x90000000, size: 0x10000000, type: 1

KERN: allocate_io_interrupt_vectors: allocated 1 vectors starting from 18

KERN: msi_allocate_vectors: allocated 1 vectors starting from 18

KERN: [idualwifi7260] (iwm) bus_alloc_resource(1, [1], 0x0, 0xffffffff, 0x1,0x2)

KERN: msi enabled: 0x0081

KERN: [idualwifi7260] (iwm) iwm_read_firmware: unknown firmware section 512, abort

KERN: [idualwifi7260] (iwm) firmware parse error -2147483643, section type 512

KERN: [idualwifi7260] (iwm) iwm_read_firmware: failed -2147483643

KERN: [idualwifi7260] (iwm) Failed to start INIT ucode: -2147483643

comment:6 Changed 5 months ago by kim1963

https://git.haiku-os.org/haiku/tree/src/add-ons/kernel/drivers/network/wlan/idualwifi7260/glue.c#n29

HAIKU_FBSD_WLAN_DRIVER_GLUE(idualwifi7260, iwm, pci)

NO_HAIKU_FBSD_MII_DRIVER();

NO_HAIKU_REENABLE_INTERRUPTS();

HAIKU_DRIVER_REQUIREMENTS(FBSD_TASKQUEUES | FBSD_WLAN);

HAIKU_FIRMWARE_VERSION(1);

HAIKU_FIRMWARE_NAME_MAP(6) = {

{"iwm3160fw", "iwm-3160-17.ucode"},

{"iwm7260fw", "iwm-7260-17.ucode"},

{"iwm7265fw", "iwm-7265-17.ucode"},

{"iwm7265Dfw", "iwm-7265D-22.ucode"},

{"iwm8000Cfw", "iwm-8000C-22.ucode"},

{"iwm8265fw", "iwm-8265-22.ucode"},

};

comment:7 Changed 4 months ago by mrentropy

Tried with 64-bit nightly hrev52730, with no success. Adding syslog from this rev.

Changed 4 months ago by mrentropy

Attachment: syslog.2 added

Syslog from hrev52730

Changed 4 months ago by cb88

Attachment: syslog.3 added

hrev52750 iwm broken for me, wifi was working on beta1

comment:8 Changed 4 months ago by waddlesplash

See my comment in the other ticket: the "unknown firmware chunk 512" affects FreeBSD too, it's a 32-bit specific bug. 64-bit works.

comment:9 Changed 4 months ago by cb88

Not sure what othe ticket you are refering to. I'm updating my other PC with realtek at the moment so I'll update there shortly. Odd that this occurs now and didn't before though I guess they don't test on 32bit that much.

comment:10 Changed 4 months ago by waddlesplash

Resolution: fixed
Status: newclosed

comment:11 Changed 4 months ago by waddlesplash

For those with "could not load the [0] uCode section", retest after hrev52792.

comment:12 Changed 4 months ago by masaol

I've tried the latest commit, the problem still exists

KERN: pci_reserve_device(3, 0, 0, idualwifi7260) KERN: [idualwifi7260] (iwm) bus_alloc_resource(3, [16], 0x0, 0xffffffffffffffff, 0x1,0x2) KERN: [idualwifi7260] (iwm) bus_alloc_resource(1, [1], 0x0, 0xffffffffffffffff, 0x1,0x2) KERN: [idualwifi7260] (iwm) fw chunk addr 0x800000 len 81920 failed to load KERN: [idualwifi7260] (iwm) iwm_pcie_load_section: Could not load the [0] uCode section KERN: [idualwifi7260] (iwm) iwm_start_fw: failed -2147483639 KERN: [idualwifi7260] (iwm) Failed to start INIT ucode: -2147483639 KERN: pci_unreserve_device(3, 0, 0, idualwifi7260)

Version 0, edited 4 months ago by masaol (next)

Changed 4 months ago by masaol

Attachment: syslog.4 added

hrev52792, x64

comment:13 Changed 4 months ago by masaol

Resolution: fixed
Status: closedreopened

comment:14 Changed 4 months ago by cb88

It should probably be noted that on my Lenovo laptops they only load wifi from a fresh boot, regardless of the OS. Often enough a warm boot results in the wifi chip not coming up.

comment:15 Changed 4 months ago by waddlesplash

Yes, I have the same issue, but I get a different error in that case (the ucode loads successfully but then commands time out.)

comment:16 Changed 3 months ago by waddlesplash

So, I got access to some 3165 hardware, and it works fine. The RTL81xx ethernet chipset in this device also works. So I don't know what's going on here :/

Changed 2 months ago by mrentropy

Attachment: syslog-hrev53001 added

Syslog from hrev53001 by request

comment:17 Changed 3 weeks ago by luroh

Summary: Intel iwm driver not loading for idualwifi7260[8086:3165] Intel iwm driver not loading for idualwifi7260
Note: See TracTickets for help on using tickets.