Opened 9 months ago

Last modified 6 weeks ago

#14368 new bug

No display output Intel Extreme

Reported by: bbjimmy Owned by: kallisti5
Priority: normal Milestone: R1/beta2
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev52197

device Display controller (VGA compatible controller, VGA controller) [3|0|0]

vendor 8086: Intel Corporation device 2562: 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device

The monitor complains "no inmput, check the cable"

This graphics driver worked before the recent re-factor. Until recently, I used the pre-re-factor driver and accelerant. with recent changes in the kernel, this no-longer works.

Attachments (1)

syslog (199.0 KB) - added by bbjimmy 9 months ago.
log of system with no display outout.

Download all attachments as: .zip

Change History (6)

Changed 9 months ago by bbjimmy

Attachment: syslog added

log of system with no display outout.

comment:1 Changed 9 months ago by miqlas

I think he means he used the old driver from non-packaged and due the recent changes in the kernel the old driver doesn't working anymore, and he is unable to use the current driver.

Recent change should be the "clone non-user-cloneable kernel area" change The refactor is not so recent, around 2 years alredy or more.

comment:2 Changed 9 months ago by bbjimmy

That's right, this is an old regression that I thought was fixed as I forgot that I had to place a driver in ~/config/non-packaged to get my system working properly. I have been updating the system regularly since then with no issues. ( note for testing drivers ~/config/non-packaged ovwerrides /boot/system and /boot/system/non-packaged and does not require black-listing the driver.)

The "clone non-user-cloneable kernel area" change broke the driver I had in ~/config/non-packaged.

Version 0, edited 9 months ago by bbjimmy (next)

comment:3 Changed 7 months ago by pulkomandy

Milestone: UnscheduledR1/beta2

comment:4 Changed 7 weeks ago by waddlesplash

Please retest after hrev53040.

comment:5 Changed 6 weeks ago by bbjimmy

Just tried on hrev53043 and the issue is still persists.

Note: See TracTickets for help on using tickets.