Opened 2 years ago

Last modified 9 months ago

#14368 in-progress bug

No display output Intel Extreme

Reported by: bbjimmy Owned by: pulkomandy
Priority: normal Milestone: R1/beta3
Component: Drivers/Graphics/intel_extreme/8xx Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #13889
Platform: All



device Display controller (VGA compatible controller, VGA controller) [3|0|0]

vendor 8086: Intel Corporation device 2562: 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device

The monitor complains "no inmput, check the cable"

This graphics driver worked before the recent re-factor. Until recently, I used the pre-re-factor driver and accelerant. with recent changes in the kernel, this no-longer works.

Attachments (2)

syslog (199.0 KB ) - added by bbjimmy 2 years ago.
log of system with no display outout.
syslog.old (512.0 KB ) - added by bbjimmy 9 months ago.
updated syslog

Download all attachments as: .zip

Change History (18)

by bbjimmy, 2 years ago

Attachment: syslog added

log of system with no display outout.

comment:1 by miqlas, 2 years ago

I think he means he used the old driver from non-packaged and due the recent changes in the kernel the old driver doesn't working anymore, and he is unable to use the current driver.

Recent change should be the "clone non-user-cloneable kernel area" change The refactor is not so recent, around 2 years alredy or more.

comment:2 by bbjimmy, 2 years ago

That's right, this is an old regression that I thought was fixed as I forgot that I had to place a driver in ~/config/non-packaged to get my system working properly. I have been updating the system regularly since then with no issues. ( note for testing drivers ~/config/non-packaged overrides /boot/system and /boot/system/non-packaged and does not require black-listing the driver.)

The "clone non-user-cloneable kernel area" change broke the driver I had in ~/config/non-packaged.

Last edited 2 years ago by bbjimmy (previous) (diff)

comment:3 by pulkomandy, 2 years ago

Milestone: UnscheduledR1/beta2

comment:4 by waddlesplash, 22 months ago

Please retest after hrev53040.

comment:5 by bbjimmy, 22 months ago

Just tried on hrev53043 and the issue is still persists.

comment:6 by pulkomandy, 16 months ago


Please try with

For your convenience I have built (for x86_gcc2) the accelerant that you can put in non-packaged for testing:

If it still doesn't work, please attach a new syslog.

comment:7 by pulkomandy, 16 months ago

Blocking: 13889 added

comment:8 by pulkomandy, 16 months ago

Component: Drivers/Graphics/intel_extremeDrivers/Graphics/intel_extreme/8xx
Owner: changed from kallisti5 to pulkomandy

comment:9 by pulkomandy, 16 months ago

Status: newin-progress

comment:10 by korli, 14 months ago

Please check with hrev53618 or newer.

comment:11 by pulkomandy, 13 months ago

Hi, To investigate this further I really need an updated syslog, as there is extra tracing that would help me understand what is happening. If possible, please try with hrev53661 or newer.

comment:12 by pulkomandy, 12 months ago

Milestone: R1/beta2R1/beta3

Move intel_extreme tickets where the original reporter is not responding to beta3. They can be moved back if we get some feedback, but otherwise, no progress will be made. So let's focus on people who keep their bugreports up to date.

by bbjimmy, 9 months ago

Attachment: syslog.old added

updated syslog

comment:13 by bbjimmy, 9 months ago

I still get nothing after the splash screen on hrev54115 with the intel extreme driver enabled.

comment:14 by pulkomandy, 9 months ago

Hi, Your syslog does not have any message from the accelerant (only the driver), which is strange.

Is the accelerant blacklisted? Did you enable failsafe video mode in the kernel settings? Did you try a clean install?

I can imagine that there is a panic during the initialization, so the logs from the accelerant would not be written to disk. You could confirm that by typing reboot (+enter) and see if the machine reboot (that would confirm you were at a KDL prompt). In that case, does the machine have a serial port? Would it be possible to get a serial log from there to get the panic message?

comment:15 by bbjimmy, 9 months ago

Is the accelerant blacklisted?


The only thing disabled is usb stuff.

Did you enable failsafe video mode in the kernel settings?


It is normaly enabled in kernel settings, I had to disable it to try the intel extreme driver again.

Did you try a clean install?


comment:16 by bbjimmy, 9 months ago

Definately not kdl. The system needs to be powered down to reboot.

Note: See TracTickets for help on using tickets.