Opened 10 months ago

Closed 3 months ago

Last modified 2 months ago

#15458 closed bug (fixed)

WebPositive rebased crash on URL

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: R1/beta2
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description (last modified by vidrep)

HaikuWebKit 1.6.9 WebKit 608.1.30

Crash on the following URL:

https://www.foxnews.com/science/nasa-astronaut-moon-jackpot-space-mining-polar-ice-astronaut

Attachments (3)

Change History (18)

comment:1 by vidrep, 10 months ago

I had another crash on the same URL. The second time, some audio got stuck in a loop and I had to kill WebPositive from TeamMonitor. Second debug report attached.

comment:2 by diver, 10 months ago

Both reports are incomplete.

comment:3 by vidrep, 10 months ago

Description: modified (diff)

comment:4 by vidrep, 3 months ago

hrev54229+3 x86_64 HaikuWebKit 1.6.9 WebKit 610.1.9

Still crashes on latest commit

Debug report attached

comment:5 by X512, 3 months ago

I know and already fixed this issue locally. I upload path later.

Version 0, edited 3 months ago by X512 (next)

comment:6 by waddlesplash, 3 months ago

X512: If your patch works, can you please submit it for review? We would like to release a new WebKit in time for beta2, but we would prefer to fix regressions first.

comment:7 by pulkomandy, 3 months ago

"in time for beta2" sounds unlikely at this point. I may manage to finish running the test suite today if Python doesn't crash (it's my 4th or 5th attempt to run it, each time with a different problem). Then I need some time to analyse the results and see which are important regressions and need a fix before making a release.

I think it's better to do that after beta2 and maybe update the webkit package in the beta2 repos later on (or do a beta3 if we have accumulated enough changes until then to justify it).

comment:9 by X512, 3 months ago

It is annoying to make poll requests, why GitHub do not accept patch files? I often get fatal: packfile .git/objects/pack/pack-ab36c9a68f870060114341fac8c873d549467667.pack cannot be mapped: Out of memory errors and need close everything to avoid error. System is x86_64 and has 8 GB of RAM.

8GB not enougth for uploading one short line is stupid.

Last edited 3 months ago by X512 (previous) (diff)

comment:10 by pulkomandy, 3 months ago

You can attach patch files to trac tickets for WebKit, I think that works as well as github (especially for such changes, there isn't too much to review).

I'm not sure if our Gerrit would be happy with hosting the WebKit repo. It's just huge with everything in it (not only webkit sources, but also their website and blog, and the testsuite). So yes it's pushing git to its limits. I think I don't have this problem on 32bit system because there git tries to map only smaller blocks at a time?

comment:11 by X512, 3 months ago

All WebKit regressions that I know are now fixed. If someone know another regressions, please report.

Last edited 3 months ago by X512 (previous) (diff)

comment:12 by pulkomandy, 3 months ago

I'm running the webkit testsuite tonight with your changes to see the impact there (probably positive impact). If all goes well I'll start preparing a release. Thanks a lot for fixing these issues :)

comment:13 by waddlesplash, 3 months ago

Resolution: fixed
Status: newclosed

comment:14 by vidrep, 3 months ago

Appears to be fixed now. Tested with rebased branch HaikuWebKit 1.6.9 WebKit 610.1.9

Last edited 3 months ago by vidrep (previous) (diff)

comment:15 by nielx, 2 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

(final time)

Note: See TracTickets for help on using tickets.