Opened 9 months ago

Closed 6 months ago

Last modified 4 months ago

#15472 closed bug (fixed)

clementine: audio cd buffering and KDL

Reported by: cocobean Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: System/Kernel Version: R1/Development
Keywords: clementine Cc:
Blocked By: Blocking: #14564
Platform: All

Description

Erratic buffering issues during audio CD loading and playback. Adding multiple audio WAV files to playlist from audio CD may cause a KDL in some cases.

Haiku is installed on physical x86 hardware with an internal CD player.

For KDL info, see: https://github.com/haikuports/haikuports/issues/4348

URL: https://www.clementine-player.org/ Version: Clementine 1.3.1-git~4 Haiku hrev52295+129 x86_64

Attachments (2)

clementine_cocobean_2_2.jpg (69.6 KB ) - added by cocobean 9 months ago.
GPF/KDL adding audio CD WAV files using Clementine 1.31 with Haiku R1B1.
clementine-1.3.1-git-5_haiku_r1b1_cocobean.jpg (927.0 KB ) - added by cocobean 6 months ago.
clementine 1.3.1~git-5 and Haiku R1B1 (hrev52295+132 x86_64, full-sync 02-09-2020)

Download all attachments as: .zip

Change History (13)

comment:1 by waddlesplash, 9 months ago

The back-trace is incomplete. Please run "sc -d" at the prompt and take another picture.

by cocobean, 9 months ago

Attachment: clementine_cocobean_2_2.jpg added

GPF/KDL adding audio CD WAV files using Clementine 1.31 with Haiku R1B1.

comment:2 by axeld, 9 months ago

Does it use cddafs or is it directly using SCSI to access the CD-ROM?

comment:3 by cocobean, 9 months ago

cddafs/scsi_cd. SCSI-3/mmc (MMC-3) CD-R/CD-RW driver (mmc_cdr) w/ internal HP DVD SATA drive and retail audio CD. Seems fine with QMPlay2. A warning message reads: DMA resid 0 for 'read buffer', actual data is too short.

NOTE: I just retested it and it loads 12 audio tracks with no issue. So, random error - not consistent each time. The condition happens randomly on adding of >=5-12 audio tracks into it.

Last edited 9 months ago by cocobean (previous) (diff)

comment:4 by korli, 9 months ago

Could you test on a recent nightly? at least hrev53500

comment:5 by waddlesplash, 9 months ago

Blocked By: 14564 added

Seems this is a likely dupe of #14564. However, I'm not closing it, since the causes are very different, and this one is actually reproducible.

comment:6 by cocobean, 9 months ago

Tested on hrev53552 x86. Physical hardware w/internal CD/DVD player Using Haiku MediaKit with Clementine 1.3.1 x86:

  1. Streaming radio channels work fine with audio playback. No issues. Audio equalizer works fine.
  1. Tested two retail audio CDs, 12-16 tracks loaded each, no KDL/GFT crashes. Audio CD playback has buffering issues observed during track playback. Audio may stop playing - waveform display and CD still plays until an eventual 'freeze/halt' - but I can still stop/modify playback with GUI.

NOTE: Tested same audio CD procedure with QMPLay2. Works as expected. No playback buffering, KDL issues, or audible audio signal dropouts. Tested on both x86 and x86_64.

Last edited 9 months ago by cocobean (previous) (diff)

comment:7 by cocobean, 6 months ago

Tested with clementine 1.3.1~git-5 and Haiku R1B1 (hrev52295+132 x86_64, full-sync 02/09/2020).

1.Loaded 14 tracks and track info from CD without any issues.

  1. Played first track. Loads track and starts playing, then crashes into KDL.

RESULT: KDL / GPF (Error code 0x0)

Version 2, edited 6 months ago by cocobean (previous) (next) (diff)

by cocobean, 6 months ago

clementine 1.3.1~git-5 and Haiku R1B1 (hrev52295+132 x86_64, full-sync 02-09-2020)

comment:8 by waddlesplash, 6 months ago

Please retest under a nightly, and see if the crash occurs there.

comment:9 by cocobean, 6 months ago

KDL / GPF seems resolved per hrev53888 x86_gcc2 testing. No crash issues within playback session.

comment:10 by waddlesplash, 6 months ago

Blocked By: 14564 removed
Blocking: 14564 added
Resolution: fixed
Status: newclosed

OK, presuming fixed then.

comment:11 by nielx, 4 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.