Opened 5 months ago

Closed 3 months ago

#16624 closed bug (fixed)

[Tracker] Desktop font turned black

Reported by: lorglas Owned by: nephele
Priority: high Milestone: R1/beta3
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #16627
Platform: All

Description (last modified by diver)

After update to hrev54742 x86_gcc2 the Desktop font looks not good.

Why it was changed?

Attachments (1)

desktop.png (347.2 KB ) - added by lorglas 5 months ago.

Download all attachments as: .zip

Change History (12)

by lorglas, 5 months ago

Attachment: desktop.png added

comment:1 by lorglas, 5 months ago

Description: modified (diff)

comment:2 by diver, 5 months ago

Component: PreferencesApplications/Tracker
Description: modified (diff)
Platform: x86All
Summary: Desktop Fonts look like ....[Tracker] Desktop font turned black

comment:3 by diver, 5 months ago

Owner: changed from nobody to nephele
Status: newassigned
Version: R1/beta2R1/Development

comment:4 by nephele, 4 months ago

Hey, The intent of this change is to make sure that tracker uses the document text color per default, only falling back to the black/white text if the contrast is too low.

The problem is a bit that the previous check whether the window was the desktop was a bit broken, so i did remove it. The current version does check the desktop bg color, but only uses black or white if the contrast is too low, now i could increase the needed contrast for this, but i am unsure if this will fix it in this case.

comment:5 by waddlesplash, 4 months ago

Milestone: UnscheduledR1/beta3
Priority: normalhigh

comment:6 by bbjimmy, 4 months ago

Document text is simply the wrong color to use for the Desktop text. The default document background is white or close to, and the default desktop background is usually much darker than that. We may need a new category for desktop text color, or go back to using black or white.

comment:7 by X512, 4 months ago

Document text is simply the wrong color to use for the Desktop text.

+1.

White text color it better suited for default desktop background color.

comment:8 by nephele, 4 months ago

In this case i might try to instead fix the is desktop check (and properly rename it to "had costum background" or something), aswell as introduce a per-directory text color, to be set via the background prefs.

comment:9 by diver, 4 months ago

Blocking: 16627 added

comment:10 by nephele, 4 months ago

please retest after hrev54800

(To me the issue appears to be gone, but i am not perfectly sure that i have the right bg color to test)

comment:11 by pulkomandy, 3 months ago

Resolution: fixed
Status: assignedclosed

The algorithm used in hrev54800 gives good results, and is back to white on the default blue desktop.

Note: See TracTickets for help on using tickets.