Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1900 closed bug (fixed)

PANIC: page fault, but interrupts were disabled, ...

Reported by: stippi Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

... Touching address 0x00000005 from eip 0x8005f5b6

stack crawl as follows:

... panic page_fault_exception int_bottom

iframe...

insert_page_after find_page_candidate steal_pages vm_pages_reserve_pages reserve_pages cache_io <kernel>file_cache_read <bfs>ReadAt <bfs>bfs_read <kernel>file_read common_user_io _user_read pre_syscall_debug_done

iframe...

<wav_reader>GetNextChunk <libmedia.so>ExtractorThread <libmedia.so>extractor_thread <libroot.so>_get_next_team_info media extractor thread_

Happened while testing certain Mindwork software under Haiku. At the point, the system was running for over 7 hours and downloaded over 4 GB of playback objects. The caches were utilising a good chunk of the 2 GB of memory, the player was just launching, so I guess the system was trying to free no more used cached pages to make room for the player.

Don't know yet if it is easily reproducable.

Change History (5)

comment:1 Changed 11 years ago by axeld

Bug #1926 is a duplicate of this one, and contains a slightly different stack crawl.

comment:2 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev25250.

comment:3 Changed 11 years ago by axeld

Resolution: fixed
Status: closedreopened

Oops, that was a bit too early - I actually only fixed a theoretical bug (it would only be a problem if the page_writer would ever quit, which it never does).

comment:4 Changed 11 years ago by axeld

Resolution: fixed
Status: reopenedclosed

Fixed in hrev25255.

comment:5 Changed 11 years ago by stippi

Nice! Thanks a lot Axel!

Note: See TracTickets for help on using tickets.