Opened 12 years ago

Closed 22 months ago

#1952 closed bug (no change required)

compilation stops crosscompiling x86 haiku image on linux-ppc

Reported by: tradewind Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The compilation stops on bfs.h, claiming that __swap_int is undefined in the scope.

Attachments (2)

error (7.8 KB ) - added by tradewind 12 years ago.
compiler error messages
failled_clean_build.txt.zip (331.9 KB ) - added by pieterpan 12 years ago.
Clean build (after fresh checkout) of build-cross-tools failure

Download all attachments as: .zip

Change History (7)

by tradewind, 12 years ago

Attachment: error added

compiler error messages

by pieterpan, 12 years ago

Attachment: failled_clean_build.txt.zip added

Clean build (after fresh checkout) of build-cross-tools failure

comment:1 by pieterpan, 12 years ago

A few days ago I could not build haiku after an update. I tried again today with a complete fresh svn checkout (both trunk and buildtools) of hrev24521 on ubuntu linux. Not sure what's going on, but it fails to build gcc. Might be related to this ticket, see attachment with the full checkout and build output. I zipped it, cause it's kinda large.

comment:2 by umccullough, 12 years ago

The failed build on linux x86 is a new issue due to Ingo's recent commits (i can confirm it here). You should enter a different bug for that since it's entirely unrelated to the PPC host platform issue.

I'll also send a note to the list since I stumbled across this as well last night and reverted to a prior version to succeed.

comment:3 by scottmc, 11 years ago

This looks like it should be closed as well.

comment:4 by bonefish, 11 years ago

Unless I missed it nothing has been done to remedy the problem, so I guess it still exists.

comment:5 by waddlesplash, 22 months ago

Resolution: no change required
Status: newclosed

It's been 10 years, the cross-compilation system has been overhauled at least twice since this ticket was opened. Closing; if there really is still a problem then please open a new ticket.

Note: See TracTickets for help on using tickets.