Opened 11 years ago

Closed 10 months ago

#2005 closed bug (invalid)

SB600 on HP6715b laptop finds no bootable devices.

Reported by: euan Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

HP 6715b laptop (very nice too) SB600 IDE device, single channel (Vendor 0x1002 Device 0x4380) SB600 SATA Device (Vendor 0x1002, Device 0x438c)

I don't have serial debug (yet) so screen shots attached.

Attachments (3)

DSC00672.JPG (148.8 KB) - added by euan 11 years ago.
boot screenshot (ide)
DSC00673.JPG (122.8 KB) - added by euan 11 years ago.
Ahci driver debug
hp6715b_pci_fixup.diff (2.4 KB) - added by euan 11 years ago.

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by euan

Attachment: DSC00672.JPG added

boot screenshot (ide)

Changed 11 years ago by euan

Attachment: DSC00673.JPG added

Ahci driver debug

comment:1 Changed 11 years ago by euan

oh yeah I added some code to force the controller into AHCI mode, but I think it was happily already in AHCI mode anyway on my bios (there's no options to force another mode)

comment:2 Changed 11 years ago by euan

Some log output from linux (yeah not much of use)

ahci 0000:00:12.0: controller can't do 64bit DMA, forcing 32bit
ahci 0000:00:12.0: AHCI 0001.0100 32 slots 4 ports 3 Gbps 0xf impl SATA mode
ahci 0000:00:12.0: flags: ncq ilck pm led clo pio slum part 
scsi0 : ahci
scsi1 : ahci
scsi2 : ahci
scsi3 : ahci
ata1: SATA max UDMA/133 cmd 0xf882e100 ctl 0x00000000 bmdma 0x00000000 irq 19
ata2: SATA max UDMA/133 cmd 0xf882e180 ctl 0x00000000 bmdma 0x00000000 irq 19
ata3: SATA max UDMA/133 cmd 0xf882e200 ctl 0x00000000 bmdma 0x00000000 irq 19
ata4: SATA max UDMA/133 cmd 0xf882e280 ctl 0x00000000 bmdma 0x00000000 irq 19
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1.00: ATA-7: ST9160821AS, 3.BHE, max UDMA/100
ata1.00: 312581808 sectors, multi 16: LBA48 
ata1.00: configured for UDMA/100
ata2: SATA link down (SStatus 0 SControl 0)
ata3: SATA link down (SStatus 0 SControl 0)
ata4: SATA link down (SStatus 0 SControl 0)
scsi 0:0:0:0: Direct-Access     ATA      ST9160821AS      3.BH PQ: 0 ANSI: 5
Last edited 8 years ago by diver (previous) (diff)

comment:3 Changed 11 years ago by euan

I found what the issue is from a post over at openbsd.

My laptop has overlapping memory regions:

SB600 AHCI Bar[5]  @ D0609000-D0609100 (size 100h)
SB600 Audio Bar[0] @ D0608000-D060C000 (size 4000h)

I confirmed this is the issue by adding a function in pci_fixup.c currently it just disables the audio device, and sets the bar to 0. I plan to change this to search for these two devices, check that the addresses match, and if they do (make the assumption that this pc is a an HP6715b) and move one of the BARs to an unallocated region.

I implemented a version using GetNthPciInfo() but it doesn't seem to work at all. Perhaps this api isn't quite ready yet at this stage in boot. so i'll try again tomorrow using some static variables in pci_fixup. slightly more hackish but should do the trick.

http://lists.freebsd.org/pipermail/freebsd-hardware/2007-December/004812.html

Last edited 8 years ago by diver (previous) (diff)

comment:4 Changed 11 years ago by euan

patch attached to disable the audio device for now. will need to look into remapping in a future version. AHCI now works!

Changed 11 years ago by euan

Attachment: hp6715b_pci_fixup.diff added

comment:5 Changed 9 years ago by luroh

euan, is this still a problem with a recent version of Haiku?

comment:6 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build?

comment:7 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:8 Changed 7 years ago by luroh

euan, if you and the laptop are still around, could you please check with R1 Alpha 4.1?

comment:9 Changed 14 months ago by waddlesplash

Keywords: boot-failure added

comment:10 Changed 14 months ago by waddlesplash

Blocking: 7665 removed

comment:11 Changed 10 months ago by waddlesplash

Resolution: invalid
Status: newclosed

No reply in 7 years, closing.

Note: See TracTickets for help on using tickets.