Opened 11 years ago

Closed 9 years ago

#2978 closed bug (fixed)

There is no transparencity in ShowImage if i drag&drop a cutted image.

Reported by: miqlas Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc: leavengood@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

In Haiku 28283 i try to drag and drop a section of an image to the desktop, and i see blinking around the mouse cursor, and there is no transparencity like in BeOS.

Attachments (1)

Image_clipping.jpg (68.4 KB) - added by miqlas 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by miqlas

Attachment: Image_clipping.jpg added

comment:1 Changed 11 years ago by leavengood

Cc: leavengood@… added
Component: Applications/ShowImageServers/app_server
Owner: changed from leavengood to stippi

This seems to be a problem in the app_server. Re-assigning to Stephan since he can probably debug and fix it much faster. If not I can take a look again :)

I assume the problem is in the HWInterface::_AdoptDragBitmap method. Also the dragMode parameter for AS_VIEW_DRAG_IMAGE in ServerWindow.cpp is not used.

comment:2 Changed 10 years ago by miqlas

I tested it in r 35081. There is no blinking, and flickering, but there is no transparencity too.

comment:3 Changed 9 years ago by Ka

Cant confirm this any more, the transparancity works fine and there is also no blinking in hrev39605 gcc4hybrid and gcc2hybrid.

Last edited 9 years ago by Ka (previous) (diff)

comment:4 Changed 9 years ago by stippi

Resolution: fixed
Status: newclosed

It may work for ShowImage now, but I don't remember if I implemented B_OP_BLEND as drawing mode which can be passed to the BView method that creates a drag bitmap. If not, it could be simulated easily: On the app_server side, the drag bitmap is temporarily combined with the cursor bitmap. At this step, any necessary transformation can be performed as the bitmap is converted to RGBA color space anyway. For B_OP_BLEND, the alpha channel could simply be divided by two. I am undecided whether to close the ticket, since there may be no applications left that use B_OP_BLEND instead of B_OP_ALPHA, so this missing feature may not be user visible. Ok, let's close the ticket, since it is specifically about ShowImage.

Last edited 9 years ago by stippi (previous) (diff)
Note: See TracTickets for help on using tickets.