Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3334 closed bug (fixed)

radeon driver crashes on radeon x850

Reported by: adamk Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by mmlr)

Running Haiku on native hardware (a dualcore Xeon with 2 gigs of RAM). The radeon driver crashes during the final stages of of the boot process. I can see the mouse cursor, but the screen is completely corrupted. The debug log shows:

Radeon - SYNC_TO_TOKEN: Failed waiting for token 8 (active token: 0)
Radeon - Radeon_ResetEngine:
Radeon - SYNC_TO_TOKEN: Failed waiting for token 11 (active token: 0)
Radeon - Radeon_ResetEngine:
Radeon - Radeon_DiscardAllIndirectBuffers: 3
Radeon - Radeon_DiscardAllIndirectBuffers: 4
Radeon - SYNC_TO_TOKEN: Failed waiting for token 11 (active token: 0)
Radeon - Radeon_ResetEngine:
Radeon - SYNC_TO_TOKEN: Failed waiting for token 14 (active token: 0)
Radeon - Radeon_ResetEngine:
Radeon - Radeon_DiscardAllIndirectBuffers: 4
Radeon - Radeon_DiscardAllIndirectBuffers: 3

This continues indefinitely. The token increases each time (by 3)

This is with haiku-pre-alpha-hrev28886-raw.zip

I've built a newer version from svn and will try it out shortly.

Adam

Attachments (1)

haiku-debug-log.txt (116.3 KB ) - added by adamk 11 years ago.
Full debug log.

Download all attachments as: .zip

Change History (6)

by adamk, 11 years ago

Attachment: haiku-debug-log.txt added

Full debug log.

comment:1 by adamk, 11 years ago

I have updated to 28961 and the problem is still present, so it's definitely not just an issue with that build (hrev28886) or that CD distribution.

Adam

comment:2 by adamk, 11 years ago

Appears to be fixed now. I built 29133, booted it off a usb disk, and it detected the radeon. I copied the driver and accelerant back to my 28886 distribution, and it worked fine there, too.

Closing this bug.

comment:3 by adamk, 11 years ago

Alright, I give up. I see no way to close this bug :-) Anyone who can should feel free to do so.

comment:4 by mmlr, 11 years ago

Description: modified (diff)
Resolution: fixed
Status: newclosed

I think only developers can close bugs.

comment:5 by mmlr, 11 years ago

Description: modified (diff)
Note: See TracTickets for help on using tickets.