Opened 13 years ago

Closed 9 years ago

#347 closed bug (fixed)

Imposible to boot from CD

Reported by: daneel@… Owned by: axeld
Priority: high Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc: diver, adeynichenko@…, alexey.veselovsky@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When i try to boot from CD (whitout harddisk): Could not locate any supported boot devices!

But if i try the boot manager with any harddisk, i dont have this message.

So: CDROM is not recognized as a supported boot device.

You can try my boot floppy image here: http://haiku-os.org/bugzilla/attachment.cgi?id=114

Commented in IRC (#Haiku)

Attachments (2)

d266xt_boot_fail.jpg (272.1 KB) - added by adeynichenko@… 13 years ago.
dell latitude cpi d266xt boot fail
debug_vmware.txt (7.2 KB) - added by diver 13 years ago.
This one from vmware

Download all attachments as: .zip

Change History (22)

comment:1 Changed 13 years ago by diver

Cc: diver added

comment:2 Changed 13 years ago by axeld

Status: newclosed

comment:3 Changed 13 years ago by axeld

Resolution: fixed

comment:4 Changed 13 years ago by axeld

The session module was missing. Fixed some time ago by colacoder.

comment:5 Changed 13 years ago by adeynichenko@…

Cc: adeynichenko@… added

comment:6 Changed 13 years ago by axeld

Status: closedreopened

comment:7 Changed 13 years ago by axeld

Resolution: fixed

comment:8 Changed 13 years ago by axeld

* Bug 736 has been marked as a duplicate of this bug. *

comment:9 Changed 13 years ago by adeynichenko@…

Cc: alexey.veselovsky@… added

comment:10 Changed 13 years ago by adeynichenko@…

broken configurations:

i440BX, Award BIOS i815, Award BIOS VMWare 5.5.1

comment:11 Changed 13 years ago by adeynichenko@…

(In reply to comment #3)

broken configurations:

i815ep, Award BIOS

Changed 13 years ago by adeynichenko@…

Attachment: d266xt_boot_fail.jpg added

dell latitude cpi d266xt boot fail

Changed 13 years ago by diver

Attachment: debug_vmware.txt added

This one from vmware

comment:12 Changed 13 years ago by diver

Platform: All

Strangly enough, but now i have this problem too, but i remember that i was able to boot haiku from pc 3 months ago and this bug opened 6 months ago, so there could be several problems. I attached serial debug log from vmware when haiku boots off cd. I will attach another debug log of boot on native hw.

comment:13 Changed 13 years ago by diver

boot haiku from pc should be boot haiku from cd

comment:14 Changed 13 years ago by netster403

i can verify this problem. I have a known good haiku boot cd, with the latest image (oct 12th) When boot on compaq armada laptop it fails to find the befs partition (on the cd). The chipset is Intel 82440BX/ZX. Not really a kernel bug, looks like the haiku boot manager cannot see any drive(s) (my harddrive has beos max on it, should'nt it see that also?)

comment:15 Changed 11 years ago by nielx

Milestone: R1R1/alpha1
Priority: normalhigh
Version: R1 development

Moving to Alpha 1 milestone.

comment:16 Changed 11 years ago by thenerd

I get this same error on real hardware (Dell Latitude) with an encrypted hard disk. I used TrueCrypt to encrypt the whole system drive and Haiku won't boot. It shows the same "Could not mount boot device" error message.

Not sure if that helps but it's another scenario.

comment:17 Changed 10 years ago by stippi

Since this is not a "doesn't work in general" but more of a "doesn't work on some hardware" bug, as I understand it, does this really have to be in R1/alpha? There is going to be a lot of hardware where Haiku won't boot on. Us being aware of it or not.

comment:18 Changed 10 years ago by stippi

Milestone: R1/alpha1R1

No feedback, I am moving it out of the milestone anyways, since Haiku definitely boots on at least all my computers from CD. So this should not be a blocker. See my comment above.

comment:19 Changed 10 years ago by scottmc

Does this still fail for any of the configurations listed in this ticket? Please retry using the Alpha CD or newer and report back.

comment:20 Changed 9 years ago by scottmc

Resolution: fixed
Status: reopenedclosed

It is now very possible to boot from a CD so closing this ticket. If you still have issues booting from a CD please open a new ticket and be prepared to give more details on your hardware setup, etc.

Note: See TracTickets for help on using tickets.