Opened 10 years ago

Closed 5 years ago

Last modified 16 months ago

#4510 closed bug (invalid)

Freeze on boot-up - Athlon XP 2000+, Asus A7N8X-E deluxe mainboard

Reported by: DziadekAlzheimer Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/alpha1
Keywords: Cc: johnpaul.harold@…
Blocked By: #5 Blocking:
Has a Patch: no Platform: x86

Description

When i try to boot haiku R1/A1 from DVD it freeze when tracker shows. It's normally booting, it shows blue desktop i have mouse pointer, it shows tracker with clock, but then it just freeze. I can't move the mouse, toggle num-lock and nothing else.

In Safe Mode Haiku boots up without freeze.

My hw: -AMD Athlon XP 2000+, 1,66GHz -768MB RAM (512+256) -mainboard: Asus A7N8X-E Deluxe, chipset: proably nVidia nForce 2 -graphic: ATI Radeon 9550 -one IDE HD 120GB, Asus DVD writer, LG DVD-ROM

If i can give you more feedback, please ask.

Attachments (5)

PC120381.JPG (151.5 KB ) - added by DziadekAlzheimer 9 years ago.
media_server freezes computer
PC120391.JPG (168.1 KB ) - added by DziadekAlzheimer 9 years ago.
net_server freeze
PC120382.JPG (340.8 KB ) - added by DziadekAlzheimer 9 years ago.
ints command in KDL - without Safe Mode
PC120383.JPG (275.9 KB ) - added by DziadekAlzheimer 9 years ago.
bt command in KDL - without Safe Mode - drivers/dev/net/nforce
PC120392.JPG (253.0 KB ) - added by DziadekAlzheimer 9 years ago.
bt command in KDL - after disabling 1394 controller

Download all attachments as: .zip

Change History (33)

comment:1 by Luposian, 10 years ago

I have an Asus A7N8X-X, the exact same board (nForce 2 chipset), except without Dual Channel RAM support. I am also running an AMD Athlon XP 2000+, with 512Mb RAM (two 256Mb DIMMs) and an nVidia GeForce 2 Pro (AGP) video card.

Everything works 100%. Audio. Video. Networking. Everything.

So, the motherboard cannot be at fault, unless something on the board, itself, is dying. I'd check capacitors, first. Make sure none of them are bulging at the top (at all) or leaking at all. I replaced 4 on the A7N8X-X I have and it runs great. Make sure your heatsink isn't getting clogged with dust and overheating the CPU. I had an all copper one and the fins were so thin and close together, the thing was constantly getting clogged and overheating the CPU! I'd also make sure your power supply fan is working right (spins freely). The fan on a previous power supply I had was dying and overloading the power supply, causing the computer to freeze. The fan was really hard to turn. I pulled the fan out of the power supply and the computer ran fine again, so the PSU just needed a new fan.

Dig in and look into stuff. Unless something directly on the board is going bad, that board should work perfectly. So, if the board, itself, isn't the problem, something else is. Do the usual fine-toothed comb approach. Tear down, clean up, and check everything. Try a minimal configuration. Try different combinations of hardware/peripherals or different hardware/peripherals altogether.

I'm sure the solution to your problem is very close.

comment:2 by Luposian, 10 years ago

Oops, wasn't quite paying attention to what you were saying... since you say the system runs fine in Safe Mode, what setting(s) do you use/change in Safe Mode? I'm suspecting the Radeon video card may be the culprit. Nothing directly on the mainboard, itself, should be causing a problem, I'm thinking, as your board and mine are nearly identical. And, because it boots fine in Safe Mode, that seems to dismiss there being anything wrong with the board, itself.

RAM, DVD drives, hard drive, and video card. Those are really the only differences between our systems. Try using a CD-ROM drive instead of the DVD drives. Ubuntu didn't like a DVD drive I was trying to install it from, on one system I had. Maybe Haiku doesn't like 'em either? Worth a shot. Try a different video card (nVidia GeForce 2 or 3, if possible). Try swapping out RAM, using one stick only (try both, separately), a different hard drive, or disconnect the hard drive, period.

One of these suggestions has gotta work, I'm sure of it.

comment:3 by DziadekAlzheimer, 10 years ago

Computer is working almost 24/7 on Windows so it isn't hardware problem. Maybe something with ACPI or other hard to implement things. With Ubuntu versions from 8.04 to 9.04, computer was freezing (kernel panic - num+caps-lock flash) too on random things, so it could be memory problem (but Windows XP works fine non-formatted from 4 years). In Ubuntu 9.10 Alpha 5 there is no problem and i could even install it on hard disk (but it's too slow for me).

When i have more time i'll check other hardware configurations. I belive that Haiku will be more popular than Linux, beacause it's much better planned, so i want to help you:)

comment:4 by luroh, 9 years ago

DziadekAlzheimer, any improvement with a recent version of Haiku?

comment:5 by DziadekAlzheimer, 9 years ago

Hi, I would like to work some on Haiku as a Google Code-In student, so I need working copy of Haiku:D It still doesn't work on latests nightly build (i tested few revisions). I will check hardware today. The most weird thing i have noticed, that when i'm trying to boot Haiku from USB stick, then i could try only once. Then the stick doesn't have bootloader or something. I need to check it more, because i'm not sure.

comment:6 by diver, 9 years ago

Most probably some driver is causing this. Try to use this instruction http://dev.haiku-os.org/ticket/6955#comment:17

comment:7 by DziadekAlzheimer, 9 years ago

Well, i can boot USB only once, don't know why. Data are still present when i mount it in Ubuntu. Maybe some are modified. So i have burned image on CD and tested few things. The more weird thing was, that when i put CD in and have USB stick connected, Haiku started loading from USB. Boot order was: USB, HDD, CD-ROM, so i think it means that bootloader and most files was still present on stick. In fact it haven't loaded properly...

I can load Haiku from CD only in Safe Boot mode. Computer freeze, when i try to load net_server or media_server. Nothing works... I will post screenshots with terminal output in few minutes.

by DziadekAlzheimer, 9 years ago

Attachment: PC120381.JPG added

media_server freezes computer

comment:8 by DziadekAlzheimer, 9 years ago

I will post net_server screenshot later

comment:9 by diver, 9 years ago

Seems like bootloader on the CD finds and selects BFS partition from USB and proceeds to boot from it. I beleve there is already a ticket with same symptom, can't find it, though.
So both media_server and net_server freezes your computer, right? Could you attach output of listdev command?

comment:10 by DziadekAlzheimer, 9 years ago

But CD was after HDD in boot order. I will post it later

comment:11 by diver, 9 years ago

BIOS boot order doesn't metter in this case.

Version 0, edited 9 years ago by diver (next)

comment:12 by diver, 9 years ago

Do you able to enter KDL after freeze? If yes try to issue ints command there. listdev output still would be useful.

comment:13 by DziadekAlzheimer, 9 years ago

Hi, I have few interesting things and I probably discovered which driver faults. So first: here is listdev:

device Display controller [3|80|0]
  vendor 1002: ATI Technologies Inc
  device 4173: RV350 AS [Radeon 9550] (Secondary)

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 1002: ATI Technologies Inc
  device 4153: RV350 AS [Radeon 9550]

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 10de: nVidia Corporation
  device 01e8: nForce2 AGP

device Serial bus controller (FireWire (IEEE 1394), OHCI) [c|0|10]
  vendor 10de: nVidia Corporation
  device 006e: nForce2 FireWire (IEEE 1394) Controller

device Mass storage controller (IDE interface) [1|1|8a]
  vendor 10de: nVidia Corporation
  device 0065: nForce2 IDE

device Network controller (Ethernet controller) [2|0|0]
  vendor 11ab: Marvell Technology Group Ltd.
  device 4320: 88E8001 Gigabit Ethernet Controller

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 10de: nVidia Corporation
  device 006c: nForce2 External PCI Bridge

device Multimedia controller (Multimedia audio controller) [4|1|0]
  vendor 10de: nVidia Corporation
  device 006a: nForce2 AC97 Audio Controler (MCP)

device Multimedia controller (Multimedia audio controller) [4|1|0]
  vendor 10de: nVidia Corporation
  device 006b: nForce Audio Processing Unit

device Network controller (Ethernet controller) [2|0|0]
  vendor 10de: nVidia Corporation
  device 0066: nForce2 Ethernet Controller

device Serial bus controller (USB Controller, EHCI) [c|3|20]
  vendor 10de: nVidia Corporation
  device 0068: nForce2 USB Controller

device Serial bus controller (USB Controller, OHCI) [c|3|10]
  vendor 10de: nVidia Corporation
  device 0067: nForce2 USB Controller

device Serial bus controller (USB Controller, OHCI) [c|3|10]
  vendor 10de: nVidia Corporation
  device 0067: nForce2 USB Controller

device Serial bus controller (SMBus) [c|5|0]
  vendor 10de: nVidia Corporation
  device 0064: nForce2 SMBus (MCP)

device Bridge (ISA bridge) [6|1|0]
  vendor 10de: nVidia Corporation
  device 0060: nForce2 ISA Bridge

device Memory controller (RAM memory) [5|0|0]
  vendor 10de: nVidia Corporation
  device 01ef: nForce2 Memory Controller 5

device Memory controller (RAM memory) [5|0|0]
  vendor 10de: nVidia Corporation
  device 01ec: nForce2 Memory Controller 2

device Memory controller (RAM memory) [5|0|0]
  vendor 10de: nVidia Corporation
  device 01ed: nForce2 Memory Controller 3

device Memory controller (RAM memory) [5|0|0]
  vendor 10de: nVidia Corporation
  device 01ee: nForce2 Memory Controller 4

device Memory controller (RAM memory) [5|0|0]
  vendor 10de: nVidia Corporation
  device 01eb: nForce2 Memory Controller 1

device Bridge (Host bridge) [6|0|0]
  vendor 10de: nVidia Corporation
  device 01e0: nForce2 IGP2

by DziadekAlzheimer, 9 years ago

Attachment: PC120391.JPG added

net_server freeze

by DziadekAlzheimer, 9 years ago

Attachment: PC120382.JPG added

ints command in KDL - without Safe Mode

by DziadekAlzheimer, 9 years ago

Attachment: PC120383.JPG added

bt command in KDL - without Safe Mode - drivers/dev/net/nforce

comment:14 by DziadekAlzheimer, 9 years ago

Well, after freezing computer with media_ and net_server in Safe Mode i can't open KDL (once some white lines on top of the screen appeared, but nothing else), so every screen in KDL is made after trying normal boot (from CD, but without Safe Mode enabled). As i noticed in bt command, there is something about nforce, so i tried to disable some peripherals in BIOS. So, it's important that Haiku boots up normally when I disable 1394 (firewire) controller. But when i enabled it, but disabled nforce LAN controller it have been working once too. But in general it sometimes boot, and sometimes not. So look at the screenshots at the bottom. I think that there is something wrong with nforce driver.

Last edited 9 years ago by DziadekAlzheimer (previous) (diff)

comment:15 by anevilyak, 9 years ago

Blocked By: 5 added

Your problem is most likely related to interrupt sharing. You have two ethernet controllers and a USB controller sharing IRQs, which is something most of the FreeBSD-based network drivers aren't really geared towards dealing with since they assume the OS has configured everything such that that situation doesn't happen. Another victim of #5.

by DziadekAlzheimer, 9 years ago

Attachment: PC120392.JPG added

bt command in KDL - after disabling 1394 controller

comment:16 by DziadekAlzheimer, 9 years ago

PC120392.JPG - this one is after disabling LAN controller off course

comment:17 by diver, 9 years ago

Try to remove one of the following drivers:
/system/add-ons/kernel/drivers/bin/syskonnect
/system/add-ons/kernel/drivers/bin/nforce
/system/add-ons/kernel/drivers/bin/fw_raw
/system/add-ons/kernel/bus_managers/firewire

comment:18 by john-paul.harold, 9 years ago

Cc: johnpaul.harold@… added

comment:19 by diver, 8 years ago

Can you try on a recent revision?

comment:20 by DziadekAlzheimer, 8 years ago

Unfortunately nothing has changed. It still freezes.

comment:21 by scottmc, 8 years ago

Blocking: 7665 added

comment:22 by tqh, 8 years ago

This might have been fixed with #8111 which was applied in hrev44025. Please test with nightly that has this change.

comment:23 by pragmavalue, 8 years ago

I have Asus A7N8X v2.0, nForce2-U400, Athlon XP 2000+ with ATI Radeon 9550 and i have a Kernel Panic: No boot device detected I tested with Haiku 43966. System works only in Safe mode ON.

comment:24 by pragmavalue, 7 years ago

I have try with hrevr1alpha4-44597 and work fine

Thanks

comment:25 by scottmc, 7 years ago

@DziadekAlzheimer can you retest this one on the same hardware with R1/Alpha4?

in reply to:  25 comment:26 by DziadekAlzheimer, 7 years ago

Replying to scottmc:

@DziadekAlzheimer can you retest this one on the same hardware with R1/Alpha4?

I have modified computer a lot, so unfortunately I'm not able to reproduce previous configuration.

comment:27 by luroh, 5 years ago

Resolution: invalid
Status: newclosed

Not possible to retest any longer, closing.

comment:28 by waddlesplash, 16 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.