Opened 10 years ago

Last modified 10 years ago

#4761 new bug

Unable to mount magneto optical disks read/write with USB drive.

Reported by: jrash Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I am unable to mount disks read/write using my "I-O Data MOP2-U640P" USB magneto optical disk drive. When I click "Mount Read/Write" in the Mounting Volume warning message the disk still mounts read-only. If I mount the disk via the command line I am also unable to mount the disk read/write. I can use DriveSetup to format the disk as BFS and the drive mounts read/write fine under Windows and Mac OS X.

Drive shows up as "Fujitsu MCN3064UB USB Device" under Windows.

df showing drive mounted:

/MoDisk bfs 217.9M 213.6M QAM-P-- /dev/disk/usb/0/0/raw

Attachments (4)

gx280_listdev.txt (2.6 KB) - added by jrash 10 years ago.
listdev output of machine with drive attached
gx280_listusb.txt (9.0 KB) - added by jrash 10 years ago.
listusb output of machine with drive attached
gx280_listimage.txt (1.6 KB) - added by jrash 10 years ago.
gx280_syslog.txt (151.5 KB) - added by jrash 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by jrash

Attachment: gx280_listdev.txt added

listdev output of machine with drive attached

Changed 10 years ago by jrash

Attachment: gx280_listusb.txt added

listusb output of machine with drive attached

Changed 10 years ago by jrash

Attachment: gx280_listimage.txt added

Changed 10 years ago by jrash

Attachment: gx280_syslog.txt added

comment:1 Changed 10 years ago by mmlr

Component: Drivers/USBSystem/Kernel
Owner: changed from mmlr to nobody

Since usb_disk doesn't actually mark any device as read-only, this would be a general problem, likely in the disk device manager or the filesystem. The fact that you could format the drive proves that usb_disk can access it writable at least.

Note: See TracTickets for help on using tickets.