Opened 10 years ago

Closed 9 years ago

#4788 closed bug (fixed)

BTextToolTip: Text Truncated

Reported by: bonefish Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku hrev33396 with Debugger related changes up to hrev33591. The tool tip window is too small, so the second line gets truncated (attached tooltip-truncated.png). For comparison the second attached screenshot (tooltip-ok.png) has a wider window, not truncating the text.

Tested with Debugger and crashing_app.

Attachments (2)

tooltip-truncated.png (52.3 KB ) - added by bonefish 10 years ago.
tool tip truncated
tooltip-ok.png (50.9 KB ) - added by bonefish 10 years ago.
tool tip not truncated

Download all attachments as: .zip

Change History (4)

by bonefish, 10 years ago

Attachment: tooltip-truncated.png added

tool tip truncated

by bonefish, 10 years ago

Attachment: tooltip-ok.png added

tool tip not truncated

comment:1 by axeld, 10 years ago

I would assume this is a bug in BTextView's layout code.

comment:2 by zooey, 9 years ago

Resolution: fixed
Status: newclosed

Closing - I'm unable to reproduce this with hrev38006, perhaps fixed by hrev36217?

Note: See TracTickets for help on using tickets.