Opened 14 years ago

Closed 16 months ago

Last modified 16 months ago

#511 closed bug (fixed)

[ScreenSaver] Many stability issues and other problems

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Preferences/ScreenSaver Version: R1/Development
Keywords: Cc:
Blocked By: #10582, #10583, #10584, #10585, #10586, #10587, #10588, #10589, #10590, #10592, #10593, #10594, #10595, #10596, #10597, #10600, #10601, #10604 Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

I will attach my screensaver collection (115 items -2,4Mb) which i used for testing Haiku's ScreenSavers. Good news is that most of them (~100) seems to work, didn't test them in fullscreen mode though. Here are what i've found for the rest of them:

*1. I've started ScreenSaver from Terminal and on every ssaver selection i got

"runtime_loader: cannot open file /boot/beos/system/add-ons/Screen

Savers/<screensaver_name>".

Tip: open ~/config/settings window to delete screensaver_settings file when ScreenSaver start to crash on start. I think this is something to work out too.

*2. This screensavers will crash ScreenSaver pref: DS_Wobble: Segment violation KanjiSaver: Segment violation LicenseBreaker: Segment violation MeltdownBlur: Trying to delete a view that belongs to a window.Call RemoveSelf first. PrimalVision: Trying to delete a view that belongs to a window.Call RemoveSelf first. Roto_saver: elf_resolve_symbol: could not resolve symbol SetiSaver: Segment violation Sphere: Segment violation ZeroWing: addon_file ain't readable. darn! ChaoticLine: have some problems too, don't remember. Samhain: will freeze ScreenSaver. MapSaver: !!!Haiku will reboot!!! BrainWash: !!!Haiku will became black&white!!! IdleMind: ScreenSaver will close.

*3. Screensavers are wrongly sorted in the end of that list. *4. Almost all ssaver have font sensitive issues. (e.g. Nebula ;-) ) *5. ScreenSaver itself isn't font sensetive. *6. Running almost every screensaver in fullscreen will not let you out. You have to switch to another workspace and kill screen_blanker. (test case: Nebula) *7. After you killed screen_blanker in #6 via team monitor switch to first workspace, team monitor will be behind ScreenSaver pref. *8. If you have this savers installed and delete ScreenSaver_settings, after ScreenSaver start it will not select 1st module, but 6th or 7th instead. *9. Module listview need to prettfy.

All in all this is collection is a good stress tests for haiku, which should show it week sides. If there is a need, i could attach back traces for every crashing module.

Attachments (20)

ScreenSaver_1.zip (840.7 KB ) - added by diver 14 years ago.
screensaver collection part 1
ScreenSaver_2.zip (817.6 KB ) - added by diver 14 years ago.
screensaver collection part 2
ScreenSaver_3.zip (823.4 KB ) - added by diver 14 years ago.
screensaver collection part 3 (last)
LicenseBreaker.png (107.7 KB ) - added by diver 11 years ago.
Sphere.png (76.2 KB ) - added by diver 11 years ago.
BrainWash.png (112.3 KB ) - added by diver 11 years ago.
ZeroWing.png (81.9 KB ) - added by diver 11 years ago.
ScreenSaver-807-debug-27-09-2013-01-17-59.report (186.6 KB ) - added by jscipione 6 years ago.
Ball Saver crash
screen_blanker-552-debug-27-09-2013-02-23-35.report (13.2 KB ) - added by jscipione 6 years ago.
Ball saver crash (last one was actually 3dmorph)
ScreenSaver-1042-debug-27-09-2013-02-32-45.report (18.3 KB ) - added by jscipione 6 years ago.
BeSwarm crash report
ScreenSaver-353-debug-27-09-2013-02-28-43.report (19.9 KB ) - added by jscipione 6 years ago.
Binary Clock crash report
screen_blanker-1226-debug-27-09-2013-01-25-27.report (10.6 KB ) - added by jscipione 6 years ago.
BSOD for BeOS R5
screen_blanker-1455-debug-27-09-2013-01-26-43.report (9.5 KB ) - added by jscipione 6 years ago.
cell_screen crash report
screen_blanker-382-debug-27-09-2013-02-21-08.report (10.6 KB ) - added by jscipione 6 years ago.
CubeSaver crash report
ScreenSaver-1721-debug-27-09-2013-02-05-44.report (29.9 KB ) - added by jscipione 6 years ago.
FlipSaver crash report
screen_blanker-1794-debug-27-09-2013-02-02-52.report (13.3 KB ) - added by jscipione 6 years ago.
Flurry crash report
screen_blanker-1592-debug-27-09-2013-01-28-16.report (13.2 KB ) - added by jscipione 6 years ago.
GLCubes crash report
screen_blanker-1455-debug-27-09-2013-01-26-43.2.report (9.5 KB ) - added by jscipione 6 years ago.
GLife crash report
screen_blanker-1226-debug-27-09-2013-01-25-27.2.report (10.6 KB ) - added by jscipione 6 years ago.
License Breaker crash report
ScreenSaver-572-debug-07-01-2016-17-27-39.report (12.7 KB ) - added by Saqlain5442 4 years ago.
This reportfile is from screen saver Flash Player.

Change History (70)

by diver, 14 years ago

Attachment: ScreenSaver_1.zip added

screensaver collection part 1

by diver, 14 years ago

Attachment: ScreenSaver_2.zip added

screensaver collection part 2

by diver, 14 years ago

Attachment: ScreenSaver_3.zip added

screensaver collection part 3 (last)

comment:1 by diver, 13 years ago

Platform: All

Some problems went away and some new problems appears. 80% of ssavers will not work without libnet.so, so i made up a link to libnetwork.so to make them work. Very often after screen_blanker crash, app_server will deadlock too. Sometimes when screensaver pref crashes and then you close debug window frozen screensaver will stay on screen until i kill gdb from processcontroller. If you select first ssaver and then hold down down arrow you will crash ScreenSaver.

All in all there is a big troubles with screensavers, so it would be nice if you could have a look at those, Axel!

comment:2 by diver, 13 years ago

If after screen_blanker crash you will quickly press ok in crash window app_server will not die!

comment:3 by jackburton, 13 years ago

Description: modified (diff)

Diver, can you recheck after hrev19891 ?

comment:4 by diver, 12 years ago

screen_blanker don't crash anymore and app_server crashed only once with bt from #634. So now ScreenSaver will crash or hang or just will not load a saver. Also some savers doesn't work in fullscreen mode, while in prview mode thay are ok. Ah and annoying slow selection of savers should be avoided if possible.

comment:5 by kaoutsis, 11 years ago

The file 'Fetcher' included in ScreenSaver_2.zip doen't appear to be a valid screensaver, or it's corrupted; i tested also on hrev5, it doesn't do anything in preview mode (selecting Fetcher the test button is disabled), and if i insist selected it as screensaver, ScreenSaver pref. just ignore it. On Haiku crashes the ScreenSaver pref. if selected.

comment:6 by aldeck, 11 years ago

Diver, can you recheck? At least some crashes could have been fixed with hrev25761 . I'll have a look at the remaining problems. Thanks!

comment:7 by diver, 11 years ago

Component: PreferencesPreferences/ScreenSaver
Summary: [ScreenSaver] Many stability and other problems[ScreenSaver] Many stability issues and other problems

*1. Fixed. *2. Trouble screensavers

DS_Wobble: works now PrimalVision: works now Roto_saver: works now ChaoticLine: works now Samhain: works now

MapSaver: don't crash anymore but doesn't work SetiSaver: don't crash anymore but doesn't work KanjiSaver: don't crash anymore, but doesn't work.

LicenseBreaker: screen_blanker crash, see LicenseBreaker.png MeltdownBlur: If you press Test it will change resolution to lowest, then screen_blanker will crash, back trace is the same as LicenseBreaker.png Sphere: Segment violation. See Sphere.png ZeroWing: addon_file ain't readable. darn! BrainWash: Running in VirtualBox will crash versa.accelerant. see BrainWash.png for backtrace IdleMind: ScreenSaver will close, but left in Deskbar

*3. Fixed *4. Invalid. *5. Fixed. *6. Fixed. *7. Probably fixed. *8. Fixed. *9. Module listview need some offset to be more pretty. But this is not belong to this bug.

by diver, 11 years ago

Attachment: LicenseBreaker.png added

by diver, 11 years ago

Attachment: Sphere.png added

by diver, 11 years ago

Attachment: BrainWash.png added

by diver, 11 years ago

Attachment: ZeroWing.png added

in reply to:  7 comment:8 by diver, 11 years ago

Please someone fix formatting in description and in my comment 7.

I would recommend to close this bug as fixed as most of the bugs are fixed now.

After that I will open new tickets about remaining bugs.

comment:9 by diver, 11 years ago

Any opinions on these?

comment:10 by diver, 11 years ago

ping!

comment:11 by axeld, 11 years ago

Just let me look into it before I say anything - may take a while, but it's on my list. Please schedule your next nagging in about 3 month ;-)

comment:12 by axeld, 11 years ago

Resolution: fixed
Status: newclosed

Just looked into BrainWash, and fixed a bug in BWindowScreen that prevented those from working. However, it still doesn't seem to work. Feel free to do as you suggested :-)

comment:13 by jscipione, 6 years ago

Resolution: fixed
Status: closedreopened
Version: R1/alpha4.1

comment:14 by jscipione, 6 years ago

Version: R1/alpha4.1R1/Development

by jscipione, 6 years ago

Ball Saver crash

by jscipione, 6 years ago

Ball saver crash (last one was actually 3dmorph)

by jscipione, 6 years ago

BeSwarm crash report

by jscipione, 6 years ago

Binary Clock crash report

by jscipione, 6 years ago

BSOD for BeOS R5

by jscipione, 6 years ago

cell_screen crash report

by jscipione, 6 years ago

CubeSaver crash report

by jscipione, 6 years ago

FlipSaver crash report

by jscipione, 6 years ago

Flurry crash report

by jscipione, 6 years ago

GLCubes crash report

by jscipione, 6 years ago

GLife crash report

by jscipione, 6 years ago

License Breaker crash report

comment:15 by jscipione, 6 years ago

I have more but I think you get the idea, a couple of screensavers crash the OS including MapSaver making debugging difficult. Others simply don't work but don't crash. Many have layout issues but that is expected.

comment:16 by jscipione, 6 years ago

Sorry the crash report descriptions don't match the reports because I reversed the order of them, but you can gleam what goes with what from the report descriptions

comment:17 by jscipione, 6 years ago

3dMorph - crashes AnalogClockSaver - works Atari Memory Test - works, no preview AttackoftheKillerBAlerts - works, no preview, font issues in settings BackgroundSaver - works Ball - works band - works BeBubbles - works BePyro - works, font issues in settings BeSwarm - crashes BeWake - works Bin95 - works, font issues in settings BinaryClock - crashes screen_blanker, settings messed up, previews OK Brainwash - changes screen resolution to 640x480, can't stop, have to reboot BSOD for BeOS R5 - crashes CBScreenSaver - works, settings messed up cell_screen - works ChaoticLine - works Circles - works, settings cut off CL-Amp - works ClockSaver - works, settings cut off Clozer - blank, settings cut off CubeSaver - doesn't load, crashes on exit CubeSaverTwo - doesn't load, crashes on exit DecayScreen - works, no preview Deco - works Distort - works but crashes on preferences changes DrunkVision - crashes DS_Wobble - crashes DuckSaver - doesn't load, casualty of PM FadePlot - works Fetcher - crashes Flash Player - crashes FlipSaver - works Forest - works FracTri - works FSOv1.1 - could not load, crashes on exit Funky Spots - works, settings messed up GalaxyScreenSaver - works Geometric Dreams - works George Fox Epistle 46 - works GLCubes - could not load, crashes on exit GLCubes2 - could not load, crashes on exit GLife - works but crashes on exit, we have an updated version in tree Gradient - works, settings cut off Hate(1) - works, settings messed up Holiday - works HopalogSaver - works IdleMind - quits window Interfade - works K.I.T.T - works, settings cut off, no preview Kablooie, works KanjiSaver - works Kernel - works Konfetti - works Latenight1 - works License Breaker - crashes MapSaver - doesn't load Matrix - works MatricCode - works, settings cut off Meltdown Blur - quits window Moire - works moreofthebuggers - crashes Mountain - works MySpots - works, settings cut off nausea - works Nebula - works, settings overlap OpenBeOS - works, settings cut off Orbit - could not load saver, crashes on exit Particle - works PentoSaver - works Ping - works, settings cut off Plasma - works, settings cut off PrialVision - works pushpin - works Puzzle - works Pyro - works RandomSaver - crashes on exit Rorschach - works Rosettes - works Rstarts - works, settings cut off Samhain - works Scooter - works SETISaver - quits window SheepSaver - doesn't load, another victim of PM shifter - works Shoots - works Sierpinski - works SlideshoSaver - works, settings overlap Slizer - works Snow - works, settings cut off Sonar - works, settings cut off Space - works, font issues in settings Sparticles - works Spider - works Spirilla - works Spots & More 1.0 - works, font and layout issues in settings Star Saver, works, no preview SuckSaver, works SuperCircles, works, font issues in settings, appears to be same as BeBubbles SuperSpots, works, settings cut off Terazzo, works TextCrawler - works TextFader - works The Hole - crashes The UnNamedOne - crashes TileSaver - works Vines - works Wolle - works, text cut off in settings XJack - works XRoger - crashes ZeroWing - works Zoom - works

comment:18 by pulkomandy, 6 years ago

I'm sure I had 3DMorph running, like, last year.

Anyway, what's the point of reopening this very old bug for probably unrelated crashes? I'd rather have a new bug (or maybe several ones) with one different problem at a time (compare the stacktraces). For example, I know BrainWash isn't running anymore, but that's because of a race condition in BDirectWindow initialisation, which doesn't even belong in screensaver kit...

comment:19 by jscipione, 6 years ago

Blocked By: 10581 added

comment:20 by jscipione, 6 years ago

Blocked By: 10582 added

comment:21 by jscipione, 6 years ago

Blocked By: 10583 added

comment:22 by jscipione, 6 years ago

Blocked By: 10584 added

comment:23 by jscipione, 6 years ago

Blocked By: 10585 added

comment:24 by jscipione, 6 years ago

Blocked By: 10586 added

comment:25 by jscipione, 6 years ago

Blocked By: 10587 added

comment:26 by jscipione, 6 years ago

Blocked By: 10588 added

comment:27 by jscipione, 6 years ago

Blocked By: 10589 added

comment:28 by jscipione, 6 years ago

Blocked By: 10590 added

comment:29 by jscipione, 6 years ago

Blocked By: 10591 added

comment:30 by jscipione, 6 years ago

Blocked By: 10592 added

comment:31 by jscipione, 6 years ago

Blocked By: 10593 added

comment:32 by jscipione, 6 years ago

Blocked By: 10594 added

comment:33 by jscipione, 6 years ago

Blocked By: 10595 added

comment:34 by jscipione, 6 years ago

Blocked By: 10596 added

comment:35 by jscipione, 6 years ago

Blocked By: 10597 added

comment:36 by jscipione, 6 years ago

Blocked By: 10598 added

comment:37 by jscipione, 6 years ago

Blocked By: 10599 added

comment:38 by jscipione, 6 years ago

Blocked By: 10600 added

comment:39 by jscipione, 6 years ago

Blocked By: 10601 added

in reply to:  18 comment:40 by jscipione, 6 years ago

Replying to pulkomandy:

I'm sure I had 3DMorph running, like, last year.

Anyway, what's the point of reopening this very old bug for probably unrelated crashes? I'd rather have a new bug (or maybe several ones) with one different problem at a time (compare the stacktraces). For example, I know BrainWash isn't running anymore, but that's because of a race condition in BDirectWindow initialisation, which doesn't even belong in screensaver kit...

Be careful what you wish for. :)

comment:41 by jscipione, 6 years ago

Blocked By: 10604 added

comment:42 by waddlesplash, 5 years ago

There have been a lot of cleanups lately. Can this be closed?

comment:43 by jscipione, 5 years ago

Blocked By: 10581 removed

#10581 is not blocked by this since the issue is not related to screen savers

Last edited 5 years ago by jscipione (previous) (diff)

comment:44 by diver, 4 years ago

This is a crash in Flash Player screensaver in SetDefaultSWF. So it's likely it's just a bug in this screensaver.

comment:45 by Saqlain5442, 4 years ago

I have tested them.On full-screen some of the are black screen with no screen saver.

comment:46 by Saqlain5442, 4 years ago

Screen saverworks or not
3dMorph works
AnalogClockSaver works
Atari Memory Test works
AttackoftheKillerBAlerts works
BackgroundSaverworks
Ball works
band works
BeBubbles works
BePyro works
BeSwarm works
BeWake works
Bin95 works
BinaryClock works
Brainwash works but can't stop it
BSOD for BeOS R5 works
CBScreenSaver works
cell_screen works
ChaoticLine works
Circles works
CLAmp works
ClockSaver works
Clozer blank
CubeSaver doesn't load
CubeSaverTwo doesn't load
DecayScreen works
Deco works
Distort works
DrunkVision works
DS_Wobble work
DuckSaver doesn't load
FadePlot works
Fetcher works
Flash Player crashes
FlipSaver works
Forest works
FracTri works
FSOv1.1 could not load
Funky Spots works
GalaxyScreenSaver works
Geometric Dreams works
George Fox Epistle 46 works
GLCubes works
GLCubes2 could not load
GLife works
Gradient works
Hate(1) works
Holiday works
HopalogSaver works
IdleMind quits window
Interfade works
K.I.T.T works
Kablooieworks
KanjiSaver works
Kernel works
Konfetti works
Latenight1 works
License Breaker works
MapSaver doesn't load
Matrix works
MatricCode works
Meltdown Blur works
Moire works
moreofthebuggers works
Mountain works
MySpots works
nausea works
Nebula works
OpenBeOS works
Orbit could not load screen saver
Particle works
PentoSaver works
Ping works
Plasma works
PrialVision works
pushpin works
Puzzle works
Pyro works
RandomSaver works
Rorschach works
Rosettes works
Rstarts works
Samhain works
Scooter works
SETISaver quits window
SheepSaver doesn't load
shifter works
Shoots works
Sierpinski works
SlideshoSaver works
Slizer works
Snow works
Sonar works
Space works
Sparticles works
Spider works
Spirilla works
Spots & More 1.0 works
Star Saverworks
SuckSaverworks
SuperCirclesworks
SuperSpots works
Terazzoworks
TextCrawler works
TextFader works
The Hole works
The UnNamedOne works
TileSaver works
Vines works
Wolle works
XJack works
XRoger works
ZeroWing works
Zoom works
Last edited 4 years ago by diver (previous) (diff)

by Saqlain5442, 4 years ago

This reportfile is from screen saver Flash Player.

comment:47 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: reopenedassigned

comment:48 by cocobean, 16 months ago

Tested with Haiku hrev52031 x86.

NOTE: DuckSaver works. Use the DuckSaver package in Haiku Depot. Working screensavers may also live in something like the http://clasquin-johnson.co.za/michel/repo/packages/beos_screensaver_collection-1.0-14-x86_gcc2.hpkg, although I created a custom hpkg test package for testing based on the included packages attached to this ticket.

Screensaver works or notbeos_screensaver_collection-1.0
BrainWash works, doesn't exit cleanlynot in package
Clozer blanknot in package
CubeSaverTwo doesn't loadnot in package
Flash Player crashesnot in package
IdleMind quits windownot in package
MapSaver missing files, doesn't loadnot in package
SETISaver blanknot in package
SheepSaver doesn't load, no resource filenot in package
ZeroWing crashesworks in package

I can suggest closing this ticket as these remaining screensavers were either removed from the tested beos_screensaver_collection-1.0 package or fixed in the package (i.e. ZeroWing). They require additional files or proper porting which are optional at this time.

Last edited 16 months ago by cocobean (previous) (diff)

comment:49 by waddlesplash, 16 months ago

Blocked By: 10591, 10598, 10599 removed
Resolution: fixed
Status: assignedclosed

comment:50 by jscipione, 16 months ago

The BeOS DuckSaver program found here: http://maybe.de/software/ducksaver/ doesn't work right on Haiku because it hard codes the directory to look for its assets (/boot/home/config/add-ons/Screen Savers/DuckSaver/) and that directory no longer exists on PM Haiku. The version on HaikuArchives https://github.com/HaikuArchives/DuckSaver uses a method only available on Haiku (Resources SetToImage) to find the assets without hardcoding directory paths so it should work fine on Haiku (but not on BeOS). https://www.haiku-os.org/docs/api/classBResources.html#a7134ad1f4514b6b5546957aade7ca77a

Note: See TracTickets for help on using tickets.