Opened 9 years ago

Closed 2 years ago

#5367 closed bug (invalid)

Deskbar doesn't remember desklink installed Replicants

Reported by: humdinger Owned by: stpere
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: desklink Cc:
Blocked By: Blocking: #9705
Has a Patch: no Platform: All

Description

This is hrev35355.

Shouldn't the Deskbar remember Replicants that were installed with desklink on every bootup?

Also, when using desklink, do I have to specify the whole path to the object? For example, is it enough to:

cd /boot/system/apps
desklink Screenshot

Or would the Deskbar not find the app and this would be correct:

desklink /boot/system/apps/Screenshot

Change History (7)

comment:1 Changed 9 years ago by stpere

Owner: changed from nobody to stpere
Status: newin-progress

comment:2 Changed 9 years ago by leavengood

Keywords: desklink added; desnklink removed

Any progress on this stpere?

I was just taking a look at it, though I've only confirmed that it still occurs in recent Haiku code. Also for what it is worth I created a Screenshot desklink with the full path to the app and it still disappeared on reboot, so I don't think think that affects this bug. Also this bug should probably be logged against Deskbar, since that is probably where the bug is.

comment:3 Changed 9 years ago by anevilyak

Blocking: 6085 added

(In #6085) That's a problem specific to those which is already tracked in #5367. Closing as duplicate.

comment:4 Changed 8 years ago by axeld

Blocking: 6085 removed

Nope, #6085 is actually a different problem.

comment:5 Changed 6 years ago by humdinger

Blocking: 9705 added

comment:6 Changed 2 years ago by Janus

This was the behavior in BeOS. To make the replicant persistent the user used to put the desklink command in the UserBootScript.

http://birdhouse.org/beos/bible/R4.5/new_apps.html#deskbar

comment:7 Changed 2 years ago by humdinger

Resolution: invalid
Status: in-progressclosed

I'll close as invalid then, thanks for checking Janus. But what if stpere finally has the solution after 7 years being "in-progress"? :)

Note: See TracTickets for help on using tickets.