Opened 10 years ago

Closed 4 weeks ago

#5388 closed bug (invalid)

Garbled screen on an Intel Mobile graphics card

Reported by: Grunt Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Drivers/Graphics/intel_extreme Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

During the install phase, and after the system booted, the screen looks garbled. Multiple vertical bands of different colors are visible, some text does not show at all, some images are distorted.

I have an Acer 5315 with a Mobile Intel display adapter (Intel 965 Express chipset).

Attached are 3 images, and I think it's the most obvious in the 3rd (freshly installed system).

Attachments (3)

DSC00585.JPG (86.4 KB ) - added by Grunt 10 years ago.
DSC00588.JPG (64.1 KB ) - added by Grunt 10 years ago.
DSC00590.JPG (75.9 KB ) - added by Grunt 10 years ago.

Download all attachments as: .zip

Change History (14)

by Grunt, 10 years ago

Attachment: DSC00585.JPG added

by Grunt, 10 years ago

Attachment: DSC00588.JPG added

by Grunt, 10 years ago

Attachment: DSC00590.JPG added

comment:1 by Grunt, 10 years ago

Priority: normalhigh

comment:2 by stippi, 10 years ago

Component: User InterfaceDrivers/Graphics/intel_extreme
Owner: changed from stippi to axeld
Priority: highnormal
Status: newassigned

For the time being, you should be able to remove/rename the "intel_extreme" driver from /boot/system/add-ons/kernel/drivers/bin. (Renaming will break a link to this driver which also disables it.) That will then give you VESA graphics. On notebooks, the VESA BIOS usually includes the native resolution of the panel, so that you don't have any drawbacks. In any case, we reserve the "high" priority for more serious bugs. I know it sucks for you if this bug doesn't get fixed (although the above should help), but please don't try to push the urgency.

comment:3 by Grunt, 10 years ago

Sorry about that.

comment:4 by stippi, 10 years ago

Hey no worries! :-) Did my suggestion about using the VESA driver work out ok for you?

comment:5 by Grunt, 10 years ago

Yes, thanks a lot!

comment:6 by axeld, 10 years ago

Looks like the pixel clock is set too high, causing the chip not being able to keep up. Can you please attach a syslog (when using the driver, of course)?

comment:7 by tidux, 9 years ago

I have a similar problem on my netbook - it's an Atom N450 with an IGP. In builds before the Atom IGP was targeted, it booted to distorted 800x600x32. In every build since then, it boots normally, but once the driver loads, the screen is completely corrupted. It looks almost like static on an analog TV used to. The underlying desktop seems to work, since the color pattern changes slightly when I move the mouse. I'll attach a screenshot once I get home and get my camera.

Version 0, edited 9 years ago by tidux (next)

comment:8 by axeld, 3 years ago

Owner: changed from axeld to nobody

comment:9 by pulkomandy, 12 months ago

Milestone: R1/beta2

comment:10 by waddlesplash, 6 months ago

Please retest after hrev53040.

comment:11 by waddlesplash, 4 weeks ago

Resolution: invalid
Status: assignedclosed

No reply.

Note: See TracTickets for help on using tickets.