Opened 9 years ago

Closed 2 months ago

#5937 closed bug (fixed)

[kernel] PANIC: free(): passed invalid pointer supposed to be in bin element size 80

Reported by: diver Owned by: mmlr
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: port heap Cc:
Blocked By: Blocking: #6884, #8145
Has a Patch: no Platform: All

Description

Observed with hrev36720 in VirtualBox 3.0.12.

Attachments (2)

kdl.png (55.8 KB) - added by diver 9 years ago.
r42858KDL.JPG (103.9 KB) - added by humdinger 7 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by diver

Attachment: kdl.png added

comment:1 Changed 9 years ago by bonefish

Keywords: port heap added

Might have the same cause as #5317 and/or #5474.

comment:2 Changed 8 years ago by bonefish

Blocking: 6884 added

(In #6884) Duplicate of #5937.

comment:3 Changed 7 years ago by humdinger

Had a similar crash with hrev42858. Attached r42858KDL.JPG in case it can shed some light. The system wasn't doing anything stressful. Just sitting there with several tabs in Web+, a Mail window, and StyledEdit window open.

Changed 7 years ago by humdinger

Attachment: r42858KDL.JPG added

comment:4 Changed 7 years ago by bonefish

Blocking: 8145 added

comment:5 Changed 7 years ago by bonefish

Owner: changed from axeld to mmlr
Status: newassigned

comment:6 Changed 7 years ago by diver

Still here in hrev43938.

comment:7 Changed 7 years ago by modeenf

When does it happen? Have you tested a newer VirtualBox? what hardware are you using/have set in VB?

Senaste VB är 4.1.14

Last edited 7 years ago by modeenf (previous) (diff)

comment:8 Changed 2 months ago by diver

Resolution: fixed
Status: assignedclosed

Haven't seen it again in several years. Assuming fixed.

Note: See TracTickets for help on using tickets.