Opened 9 years ago

Closed 5 years ago

#6076 closed enhancement (fixed)

Media Player chokes on 1080i h264 Videos

Reported by: kvdman Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Here's a video showing how MediaPlayer can't play back the said file. It shows VLC playing the same file without issue.

http://haikuware.com/images/stories/SANY0156.MP4.zip

The file itself is encoded in the same format and won't play correctly in media player. It was shot with an Xacti CG10

Attachments (4)

sysinfo (1.8 KB) - added by kvdman 9 years ago.
sysinfo.zip (1.1 KB) - added by kvdman 9 years ago.
syslog.zip (56.8 KB) - added by kvdman 9 years ago.
cpu-usage.jpg (18.5 KB) - added by kvdman 9 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 9 years ago by dlmcpaul

We have been unable to get all of ffmpegs performance enhancements working so more work needs to be done to improve the decoding performance.

There are other components to playing back video that could possible be improved.

You could help by attaching the following.

CPU Graph of VLC vs MediaPlayer Processor information (sysinfo) Was Overlay being used in MediaPlayer.

It is unfortunately difficult to profile when ffmpeg is involved.

Changed 9 years ago by kvdman

Attachment: sysinfo added

Changed 9 years ago by kvdman

Attachment: sysinfo.zip added

comment:2 Changed 9 years ago by kvdman

Attached are sysinfo, and a graph of playing the same file. The first peak shows 100% usage with overlay on, the second peak at 100% shows with overlay off. The third peak shows the file being played in VLC with overlay on. It is also at 100% but plays the file smootly where MediaPlayer doesn't.

Don't know if that helps much.

Changed 9 years ago by kvdman

Attachment: syslog.zip added

Changed 9 years ago by kvdman

Attachment: cpu-usage.jpg added

comment:3 Changed 9 years ago by dlmcpaul

If you can send an e-mail to dlmcpaul AT gmail DOT com

I will send you a version of ffmpeg plugin with performance stats on.

Then you can capture the results to see how much we need to improve for you.

comment:4 Changed 9 years ago by stippi

MediaPlayer can playback the video (slightly choppy), but the audio crashes in FFmpeg SSE2 code on my machine. VLC does not playback the video more smoothly on my machine.

comment:5 Changed 8 years ago by halilpk

Haiku revision: hrev42211 not a bug. There was no problem. Just a little freezing . System: Haiku hrev1-alpha3 on VMware workstation 8 on windows 7 32 bit

comment:6 Changed 7 years ago by korli

Please give feedback on a current revision.

comment:7 Changed 7 years ago by korli

Please give feedback on a current revision.

comment:8 Changed 7 years ago by kvdman

I can't comment. I had three computers running Haiku, since alpha 3 Haiku doesn't boot on any of them anymore.

Version 0, edited 7 years ago by kvdman (next)

comment:9 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: newclosed

File plays fine here, assuming this is fixed.

Note: See TracTickets for help on using tickets.