Opened 9 years ago

Closed 6 years ago

#6143 closed bug (fixed)

[Terminal] Clearing the screen should use the current background color instead of the default Terminal color

Reported by: oco Owned by: siarzhuk
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: gci2011 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Steps to reproduce :

  • echo -e "\E[42m" to set the background color to green for example
  • then clear.

Under Linux, all the terminal background is set to green, but under Haiku, only the prompt use the green background. The rest of the screen is set to white (my default Terminal background color).

The problem occur for the following escape sequences :

  • [K used to erase display
  • [*J used to erase a line

Found while looking at this freepascal ticket.

Attachments (3)

mc_terminal.png (170.4 KB) - added by diver 9 years ago.
hrev38300
mc_terminal_r38316.png (42.7 KB) - added by diver 9 years ago.
mc running in fedora 8 via ssh
terminal_r43238.png (92.1 KB) - added by pepol 7 years ago.
wrong behavior on hrev43238

Download all attachments as: .zip

Change History (14)

comment:1 Changed 9 years ago by pulkomandy

Owner: changed from jackburton to pulkomandy
Status: newassigned

comment:2 Changed 9 years ago by pulkomandy

hrev38316 should make [*J work better. I'm now investigating the other clear cases.

comment:3 Changed 9 years ago by diver

mc doesn't like this change, see screenshots.

Changed 9 years ago by diver

Attachment: mc_terminal.png added

Changed 9 years ago by diver

Attachment: mc_terminal_r38316.png added

mc running in fedora 8 via ssh

comment:4 Changed 9 years ago by pulkomandy

I noticed that and am looking into it. Thanks for reporting.

comment:5 Changed 9 years ago by pulkomandy

The mc problem is fixed now.

comment:6 Changed 9 years ago by diver

Which one? Text color is still green instead of white in hrev38318. And background is still partly black, which is also reproducible in mcedit.

comment:7 Changed 9 years ago by diver

Still here in hrev38424.

comment:8 Changed 7 years ago by diver

Version: R1/alpha2R1/Development

comment:9 Changed 7 years ago by pepol

Keywords: gci2011 added

The problem was checked during GCI 2011. It is still a problem.
After trying the command 'echo -e "\E[42m"' in both, Linux and Haiku (hrev43238 on VBox 4.1.4), in Linux, clearing the screen after it changes the whole terminal background to green, while in Haiku, only background of currently written text is green (input and output of commands).

Changed 7 years ago by pepol

Attachment: terminal_r43238.png added

wrong behavior on hrev43238

comment:10 Changed 7 years ago by siarzhuk

Owner: changed from pulkomandy to siarzhuk

the fire on me now. details in #6510

comment:11 Changed 6 years ago by siarzhuk

Resolution: fixed
Status: assignedclosed

Fixed in hrev45364.

Note: See TracTickets for help on using tickets.