Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#6313 closed bug (fixed)

keyboard on a Dell Studio XPS laptop not recognised

Reported by: l8night Owned by: siarzhuk
Priority: normal Milestone: R1
Component: Drivers/Keyboard/PS2 Version: R1/alpha3
Keywords: keyboard dell xps Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I can boot alpha 2 from USB on my DELL Studio XPS (i7) and everything works except the keyboard :( I can run any mouse only app, but alas nothing that requires key strokes.

Attachments (8)

syslog (405.8 KB) - added by l8night 9 years ago.
/var/log/syslog
listdev.txt (3.7 KB) - added by l8night 9 years ago.
ouput from listdev
ps2.bz2 (23.6 KB) - added by siarzhuk 8 years ago.
ps2 bus manager with activated TRACE-ing (hrev42636)
syslog.2 (418.0 KB) - added by xenonym 8 years ago.
partial syslog with me pressing a few random keys
syslog.old (512.1 KB) - added by xenonym 8 years ago.
the boot up syslog (before I remounted my other usb disc as r/w)
ps2.2.bz2 (23.6 KB) - added by siarzhuk 8 years ago.
The version of ps2 bus manager with disabled mouse.
syslog.3 (148.5 KB) - added by xenonym 8 years ago.
syslog with ps2 (.2.bz) installed
putty.log (36.7 KB) - added by Mictlantecuhtli 7 years ago.
Serial output from hrev43452

Download all attachments as: .zip

Change History (27)

comment:1 Changed 9 years ago by l8night

Just had a thought and tried a USB keyboard, worked a treat so its just the built-in keyboard that does not work.

comment:2 Changed 9 years ago by anevilyak

Can you supply the output of "listdev" from Terminal, as well as attaching a copy of /var/log/syslog? Would be helpful to have some idea as to exactly what the built-in keyboard is exposing itself as hardware-wise.

Changed 9 years ago by l8night

Attachment: syslog added

/var/log/syslog

Changed 9 years ago by l8night

Attachment: listdev.txt added

ouput from listdev

comment:3 Changed 8 years ago by xenonym

Platform: Allx86
Version: R1/alpha2R1/alpha3

comment:4 Changed 8 years ago by xenonym

Summary: alpha2 does not recognise the keyboard on a Dell Studio XPS laptopkeyboard on a Dell Studio XPS laptop not recognised

comment:5 Changed 8 years ago by xenonym

just tried alpha 3, same issue, I can use a USB keyboard, but my laptops build in keyboard does not work. (had to create a new account to updated this as I was unable to login with my old details [even with a password reset])

comment:6 Changed 8 years ago by siarzhuk

Component: - GeneralDrivers/Keyboard/PS2
Owner: changed from nobody to siarzhuk
Status: newassigned

Have you tried latest nightly builds?

comment:7 in reply to:  6 Changed 8 years ago by xenonym

no, but I will have a look to see if there is a bootable image built that I can try.

Last edited 8 years ago by xenonym (previous) (diff)

comment:8 Changed 8 years ago by xenonym

just tried haiku-nightly-hrev42636-x86gcc2hybrid-anyboot.zip same issue, every thing works except my laptop's keyboard; an external USB keyboard works but that kind of defeats the point ;)

Last edited 8 years ago by xenonym (previous) (diff)

Changed 8 years ago by siarzhuk

Attachment: ps2.bz2 added

ps2 bus manager with activated TRACE-ing (hrev42636)

comment:9 Changed 8 years ago by siarzhuk

I have prepared special version of ps2 bus manager (it was just attached) with extra tracing to acquire more information about keyboard initialization process.

Please do the following: 1) Boot your hrev42636 nightly build;

2) Download the ps2 bus manager binary and expand it into /boot/system/add-ons/kernel/bus_managers replacing existing ps2 binary;

3) delete /boot/common/var/log/syslog;

4) Reboot the system, try press some keys on keyboard for some minutes and attach the /boot/common/var/log/syslog file to this ticket.

Thank you for assistance.

comment:10 Changed 8 years ago by xenonym

look like your logging is working .... I get a sys log full off

KERN: SYNAPTICS: MS_READ get event
KERN: ps2: ps2_interrupt ctrl 0x25, data 0x80 (aux)
KERN: ps2: ps2_interrupt ctrl 0x25, data 0x00 (aux)
Last message repeated 1 time
KERN: ps2: ps2_interrupt ctrl 0x25, data 0xc0 (aux)
KERN: ps2: ps2_interrupt ctrl 0x25, data 0x00 (aux)
Last message repeated 1 time
KERN: SYNAPTICS: MS_READ get event
KERN: ps2: ps2_interrupt ctrl 0x25, data 0x80 (aux)
KERN: ps2: ps2_interrupt ctrl 0x25, data 0x00 (aux)
Last message repeated 1 time
KERN: ps2: ps2_interrupt ctrl 0x25, data 0xc0 (aux)
KERN: ps2: ps2_interrupt ctrl 0x25, data 0x00 (aux)
Last message repeated 1 time
KERN: SYNAPTICS: MS_READ get event
KERN: ps2: ps2_interrupt ctrl 0x25, data 0x80 (aux)
KERN: ps2: ps2_interrupt ctrl 0x25, data 0x00 (aux)
Last message repeated 1 time
KERN: ps2: ps2_interrupt ctrl 0x25, data 0xc0 (aux)
KERN: ps2: ps2_interrupt ctrl 0x25, data 0x00 (aux)
Last message repeated 1 time

Changed 8 years ago by xenonym

Attachment: syslog.2 added

partial syslog with me pressing a few random keys

Changed 8 years ago by xenonym

Attachment: syslog.old added

the boot up syslog (before I remounted my other usb disc as r/w)

comment:11 Changed 8 years ago by siarzhuk

1) Thank you for the logs. By the way: Have you tried to change the USB Legacy options (if available) in BIOS Setup? This BIOS option is related to emulation ps2 input devices from the USB keyboards and mouse. It can affect on the stock ps2 controller work so we should exclude this factor from our tests.

2) I see in your syslogs that the most of data comes from AUX (aux) PS2 port - that mean from the mouse (touchpad). It can be known issue with some problematic ps2 controllers that "mixes" data in such way. During my work on fixing problem with HP controller I have observed such bogus behavior in case initialization of mouse and keyboard ports simultaneously. Could you please try another test with ps2 bus manager that has mouse port switched off? I have prepared special bus manager for you, please do the same operations as you did. Thank you!

Changed 8 years ago by siarzhuk

Attachment: ps2.2.bz2 added

The version of ps2 bus manager with disabled mouse.

comment:12 Changed 8 years ago by siarzhuk

Note that just attached ps2 bus manager have no mouse support - so please take care about USB mouse before testing. I'm sorry for inconvenience.

comment:13 Changed 8 years ago by xenonym

o.k. there is a USB emulation option, when disabled alas I can not boot from USB devices so can not use your logging ps2 driver. when I boot from the overnight CD, there is not improvement the internal keyboard still does not work. I also tried your new ps2 driver which I assume has no logging as I get nothing in the syslog when I use it (and still the keyboard does not work).

Changed 8 years ago by xenonym

Attachment: syslog.3 added

syslog with ps2 (.2.bz) installed

comment:14 in reply to:  13 Changed 8 years ago by siarzhuk

Replying to xenonym:

I also tried your new ps2 driver which I assume has no logging as I get nothing in the syslog when I use it (and still the keyboard does not work).

That was a version with disabled mouse - just to test. Thank this test I see that the problem is somewhere else but the affect of mouse initialization.

The last line referencing ps2 is

2309 KERN: ps2: read_keyboard_packet: enter

so the waiting for keyboard data was started but no data come from keyboard controller. That is the problem we should solve.

Thank you for your cooperation!

comment:15 Changed 8 years ago by siarzhuk

Could you, please, try the customized version of ps2 bus managers attached to bug #7973? The first one to try is ps2.bz2, the second one ps2+enable.bz2. Looks like this is the same problem and we have a chance to fix this one too. The syslog is welcome.

Thank you!

comment:16 Changed 8 years ago by siarzhuk

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev42820. Please check and reopen in case the problem appears again.

Changed 7 years ago by Mictlantecuhtli

Attachment: putty.log added

Serial output from hrev43452

comment:17 Changed 7 years ago by Mictlantecuhtli

Resolution: fixed
Status: closedreopened

It's still not working in Microsoft's virtual machine, see putty.log.

comment:18 in reply to:  17 Changed 7 years ago by siarzhuk

Resolution: fixed
Status: reopenedclosed

Replying to Mictlantecuhtli:

It's still not working in Microsoft's virtual machine, see putty.log.

This ticket was about real hardware problem that is fixed now. Please fill the new one with more details in it (VM version etc.)

comment:19 in reply to:  17 Changed 7 years ago by siarzhuk

Replying to Mictlantecuhtli:

It's still not working in Microsoft's virtual machine, see putty.log.

Have you created the new ticket with this issue on MS Virtual Machine with more details? Could you please point me on it? Thank you!

Note: See TracTickets for help on using tickets.