Opened 9 years ago

Closed 5 years ago

#6481 closed bug (fixed)

Activity Monitor issues with count of adding gragh

Reported by: kurain Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/ActivityMonitor Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #5773
Has a Patch: no Platform: All

Description

if you add more than six graphs (in "file" menu) to the Activity Monitor, this program will crash. the nightly build that I tested is R38293 gcc2hybird in Virtual Box(3.2.8,hrev64453).my host os is windows xp sp3.

Attachments (7)

Activity Monitor crash.png (56.8 KB ) - added by kurain 9 years ago.
this shortcut is taken when Activity Mornity
ActivityMonitor_Real_Hardware.png (202.2 KB ) - added by l_n 9 years ago.
ActivityMonitor on real hardware beyond the limits of the bug
backtrace.png (36.5 KB ) - added by dru_ed 9 years ago.
infothreads.png (15.5 KB ) - added by dru_ed 9 years ago.
pagestats.png (28.8 KB ) - added by dru_ed 9 years ago.
kdl, syslog | tail, avail & page_stats
threads.png (37.6 KB ) - added by dru_ed 9 years ago.
kdl, ActivityMonitor threads
bt.png (25.7 KB ) - added by dru_ed 9 years ago.
kdl ActivityMonitor backtrace

Download all attachments as: .zip

Change History (14)

by kurain, 9 years ago

Attachment: Activity Monitor crash.png added

this shortcut is taken when Activity Mornity

comment:1 by diver, 9 years ago

Component: - GeneralApplications/ActivityMonitor
Owner: changed from nobody to axeld
Version: R1/alpha2R1/Development

by l_n, 9 years ago

ActivityMonitor on real hardware beyond the limits of the bug

comment:2 by dru_ed, 9 years ago

I see similar behavior on VMWare, Mac OS X 10.6.4 host with Haiku rev 38259 (gcc2h) when more then six graphs are added when the VM is set to use 1 core.

I was able to easily add 12 graphs when I set the VM to use 2 cores.

I have a backtrace, see attached screenshot (backtrace.png).

I added an info threads screenshot (infothreads.png).

Last edited 9 years ago by dru_ed (previous) (diff)

comment:3 by l_n, 9 years ago

I tried to replicate this per the discussion in #haiku on IRC on real hardware. I've uploaded an image showing *all* graphs enabled and ActivityMonitor still chugging along happily. My hardware is a stock Eee 1000 with the exception of the Atheros wifi card I added in place of the RaLink.

Version 0, edited 9 years ago by l_n (next)

by dru_ed, 9 years ago

Attachment: backtrace.png added

by dru_ed, 9 years ago

Attachment: infothreads.png added

comment:4 by andreasf, 9 years ago

Sounds similar to #5773.

by dru_ed, 9 years ago

Attachment: pagestats.png added

kdl, syslog | tail, avail & page_stats

by dru_ed, 9 years ago

Attachment: threads.png added

kdl, ActivityMonitor threads

by dru_ed, 9 years ago

Attachment: bt.png added

kdl ActivityMonitor backtrace

comment:5 by Coldfirex, 9 years ago

Still occurring under R39551 GCC2Hybrid.

comment:6 by pulkomandy, 5 years ago

Blocking: 5773 added

(In #5773) Closing this since the KDL is gone (at least here I can't reproduce that part). The freeze is tracked in #6481.

comment:7 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev48381. Enjoy hundreds of graphs now.

Note: See TracTickets for help on using tickets.