Opened 9 years ago

Last modified 4 years ago

#6550 assigned bug

Terminal freezes when scrolling history

Reported by: Disreali Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: gci2011 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On hrev38424 and hrev38411 scrolling back through Terminal's history using the down arrow key causes Terminal to freeze and stop responding to mouse or keyboard input, and the cursor stops blinking. A new terminal window will not open, and the original Terminal window can only by killed ProcessController or Team Monitor.

This is a recent regression.

Attachments (1)

syslog_hrev43314_terminal_freeze_scrolling_history.txt (109.6 KB) - added by Disreali 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 9 years ago by Disreali

Issue not present on a fresh install of hrev38723 nighyly-2h. Issue may have been caused by freegrep being installed on my build system that produced revs mentioned in ticket.

comment:2 Changed 8 years ago by michaelvoliveira

Not present anymore

comment:3 Changed 8 years ago by luroh

Resolution: invalid
Status: newclosed

Ok, closing.

comment:4 Changed 8 years ago by Disreali

Resolution: invalid
Status: closedreopened

Freeze is back again. Experienced on hrev39523-2h nightly from www.hiaku-files.org and on hrev39530-2h that was built on the afore mentiond nightly. Besides doing a binary search, is there anything I could do to help diagnose the issue?

Last edited 8 years ago by Disreali (previous) (diff)

comment:5 in reply to:  4 Changed 8 years ago by bonefish

Replying to Disreali:

Freeze is back again. Experienced on hrev39523-2h nightly from www.hiaku-files.org and on hrev39530-2h that was built on the afore mentiond nightly. Besides doing a binary search, is there anything I could do to help diagnose the issue?

Please provide stack traces of the Terminal's threads (as described in https://dev.haiku-os.org/ticket/6612#comment:3). The KDL session appears a few seconds after leaving it in /var/log/syslog.

comment:6 Changed 8 years ago by diver

Component: - GeneralApplications/Terminal

comment:7 Changed 7 years ago by pepol

Keywords: gci2011 added

The problem was checked during GCI 2011. It was unconfirmed on my system (hrev43238 running in VirtualBox 4.1.4)

comment:8 Changed 7 years ago by Disreali

Was just reminded of this by the GCI tester.

I found that I can get Terminal to freeze by scrolling back and forth. Sometimes it happens quickly, other times much longer. running hrev43314

@Bonefish I'm attaching KDL backtrace of Terminal. Please let me know if you would like bt from other teams.

comment:9 Changed 6 years ago by siarzhuk

Owner: changed from nobody to siarzhuk
Status: reopenedassigned

comment:10 in reply to:  8 ; Changed 6 years ago by siarzhuk

Replying to Disreali:

I found that I can get Terminal to freeze by scrolling back and forth. Sometimes it happens quickly, other times much longer. running hrev43314

Which history did you mean? The lines "above" the screen or input line history? Could yopu, please, explain step by step how do you reproduce the problem?

PS: There are funny lines in your syslog - those about beep() - may be this issue related in any way to beeping? Does sound work on this system???

comment:11 Changed 6 years ago by siarzhuk

Owner: changed from siarzhuk to nobody

I suspect this is the problem with audio playing but not Terminal itself. Reaching the end of input history in bash issues the beep() that looks like hanging in provided log.

comment:12 in reply to:  10 ; Changed 6 years ago by Disreali

Replying to siarzhuk:

Replying to Disreali:

I found that I can get Terminal to freeze by scrolling back and forth. Sometimes it happens quickly, other times much longer. running hrev43314

Which history did you mean? The lines "above" the screen or input line history? Could yopu, please, explain step by step how do you reproduce the problem?

PS: There are funny lines in your syslog - those about beep() - may be this issue related in any way to beeping? Does sound work on this system???

I am referring to the bash window's input history.

Sound does not work all the time on this system. On most boot ups I have to restart the Media Server to get sound to work, and sometimes it never actually will succeed in producing sound.

comment:13 in reply to:  12 Changed 6 years ago by siarzhuk

Replying to Disreali:

Sound does not work all the time on this system. On most boot ups I have to restart the Media Server to get sound to work, and sometimes it never actually will succeed in producing sound.

To assure that this issue is related to sound try to disable bash beep by using:

echo 'set bell-style none' >> ~/.inputrc

and try reproduce the problem again.

comment:14 Changed 4 years ago by pulkomandy

Can you still reproduce this? It doesn't happen here.

Also, does the workaround mentionned above works?

Note: See TracTickets for help on using tickets.