Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6657 closed bug (fixed)

MediaPlayer makes popping/clicking/aggresive noises when forwarding video time

Reported by: stargatefan Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by phoudoin)

If you click the time bar to advance position on the time indicator it causes loud clipping noises. Noise can be described as similar to unplugging a RCA cable from a stereo thats turned up. Implementing volume reduction/mute during playback time advancing should be a simple fix and most other media players do this.

Change History (9)

comment:1 by phoudoin, 9 years ago

Description: modified (diff)
Summary: MediaPlaeyr makes popping/clicking/aggresive noises when forwarding video timeMediaPlayer makes popping/clicking/aggresive noises when forwarding video time

comment:2 by stippi, 9 years ago

This one should be fixed in hrev38807. Can you please retest and give feedback?

comment:3 by diver, 9 years ago

In VirtualBox there's half second of silence after every seek now.

comment:4 by stippi, 9 years ago

That's ok/unavoidable, depending on the container format. What file type did you test with?

comment:5 by diver, 9 years ago

It was an .avi file with MPEG-4 part 2 video and ATSC A/52A (AC3) audio

comment:6 by stippi, 9 years ago

Ok, well with MP4 and MKV you get bits of (valid) sound even while seeking, so I consider it a problem of the AVI demuxer. (I also get no sound while seeking in AVIs). Previously, I got distorted noise in AVIs and the valid sound would start shortly after stopping to seek. So I consider the silence an improvement. The situation with my test clips is now as this: All stuff plays as well as in ffplay (for me), *except* MPEG/MPEG2 files that have drifting time stamps (chunk time stamps don't match the calculated timestamps with regards to the supposed frame rate). This problem needs to be fixed in MediaPlayer, but it may not be so easy. Considering how frustrated I was until I finally reached the state of today, I consider a moment of silence after seeking in AVIs a good compromise. :-D

comment:7 by stippi, 9 years ago

Resolution: fixed
Status: newclosed

comment:8 by stargatefan, 9 years ago

will test when nightlys are back up.

comment:9 by stargatefan, 9 years ago

tested with gcc4 h 38811 all is well, I also noticed the source comments. works great now

Version 2, edited 9 years ago by stargatefan (previous) (next) (diff)
Note: See TracTickets for help on using tickets.