Opened 10 years ago

Closed 2 months ago

Last modified 2 months ago

#6901 closed bug (fixed)

[Pulse] selecting deskbar mode closes it's settings window if it's open

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Applications/Pulse Version: R1/Development
Keywords: gci2013 Cc: puck@…
Blocked By: Blocking: #7979
Platform: All

Description

This is hrev39614 gcc4hybrid.

  • open /system/demos/Pulse
  • right click cpu image and select Settings...
  • right click cpu image and select Deskbar mode.

Attachments (1)

6901.patch (5.2 KB ) - added by puckipedia 7 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 by ctbeiser, 9 years ago

Verified on hrev43475.

comment:2 by ctbeiser, 9 years ago

Keywords: gci2011 added

comment:3 by ctbeiser, 9 years ago

This is a duplicate of 7979. This is newer, but 7979 is more comprehensive, and this bug should therefore be closed as duplicate.

comment:4 by diver, 9 years ago

Blocking: 7979 added

comment:5 by diver, 9 years ago

Thanks, ctbeiser. BTW if you put # in front of ticket number it will become a link to that bug. Like this: #7979.

comment:6 by diver, 8 years ago

Component: ApplicationsApplications/Pulse

by puckipedia, 7 years ago

Attachment: 6901.patch added

comment:7 by puckipedia, 7 years ago

patch: 01

comment:8 by puckipedia, 7 years ago

Cc: puck@… added
Keywords: gci2013 added; gci2011 removed
patch: 10

comment:9 by puckipedia, 7 years ago

I added a fix, which keeps the state of the preferences window (open, closed, which tab) in the preferences and reopens the window if it was closed previously (switching state, reopening app after reboot).

comment:10 by umccullough, 7 years ago

patch: 01

comment:11 by pulkomandy, 5 years ago

I would take a different approach, the preferences window could continue running in the independant app, instead of exiting it. Reopening the window from the replicant is cheating :)

I'm also wondering if the replicant mode should be merged with ProcessController instead?

comment:12 by diver, 5 years ago

Probably there is no need for replicant mode since we also have ProcessController.

comment:13 by pulkomandy, 2 years ago

patch: 10

comment:14 by pulkomandy, 2 years ago

Patch migrated to Gerrit: https://review.haiku-os.org/#/c/83/

comment:15 by waddlesplash, 2 months ago

Resolution: fixed
Status: newclosed

Merged in hrev54179.

comment:16 by waddlesplash, 2 months ago

Whoops, I meant hrev54180.

comment:17 by nielx, 2 months ago

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

comment:18 by nielx, 2 months ago

Milestone: R1R1/beta2
Note: See TracTickets for help on using tickets.