Opened 8 years ago

Closed 7 years ago

#7240 closed bug (duplicate)

Localized status messages too big for window

Reported by: humdinger Owned by: korli
Priority: normal Milestone: R1
Component: Applications/Installer Version: R1/Development
Keywords: Cc:
Blocked By: #5882 Blocking:
Has a Patch: no Platform: All

Description

This is hrev40513.

The area for status messages beside the logo of the Installer window can be too small for localized messages. See:

Screeshot: Bottom part of German status message is cut off.

Can the LayoutKit check for the longest localized string and create a wide enough Installer window from the start?

Attachments (1)

Install-finished-de.png (41.6 KB) - added by humdinger 8 years ago.
Screeshot: Bottom part of German status message is cut off.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by humdinger

Attachment: Install-finished-de.png added

Screeshot: Bottom part of German status message is cut off.

comment:1 Changed 8 years ago by idefix

Duplicate of ticket:5882 (and ticket:7166).

comment:2 Changed 8 years ago by phoudoin

Can the LayoutKit check for the longest localized string and create a wide enough Installer window from the start?

What's missing is !BTextView::HasHeightForWidth() and !BTextView::GetHeightForWidth() when not editable, not in a scrollview and resizable. I tried to implement it, but didn't find the time to do it right.

The LayoutKit will then automatically adjust to fit both logo and the whole status text. Dynamically. But it will also do this when the new status text is smaller enough to reduce the height, which is not the best visual effect...

Version 0, edited 8 years ago by phoudoin (next)

comment:3 Changed 8 years ago by taos

This might have been fixed in hrev42022 (see #5882).

comment:4 Changed 7 years ago by diver

Blocked By: 5882 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.