Opened 13 years ago

Closed 11 years ago

#731 closed bug (fixed)

[Cortex] media_addon_server start to eat cpu

Reported by: diver Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Kits/Media Kit Version:
Keywords: Cc: jackburton, stippi
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

If you run Cortex under vmware (which i suspect is the same under real hw with unsupported sound card) will trigger media_addon_server to load cpu 100%. Closing Cortex doesn't help, i have to kill Cortex to fix it. Tested under vmware with hrev18486, but this bug was here from beginning, after Cotex was added to the image, but i suspect it's media_addon_server to blame here.

Attachments (1)

bt.png (64.3 KB) - added by jackburton 11 years ago.
backtrace

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by jackburton

Description: modified (diff)
Platform: All

Now I also get a media_addon_server crash.

Changed 11 years ago by jackburton

Attachment: bt.png added

backtrace

comment:2 Changed 11 years ago by jackburton

Oh now I see it's a debugger call... nice choice of words, btw... :)

comment:3 Changed 11 years ago by stippi

According to the code in src/kits/media/DataExchange.cpp, it looks like either the MediaServer or the MediaAddonServer port are not found or some other write_port_etc() problem. Maybe run the media servers from the command line to get some helpful printf debug messages? (I will also try to investigate, but I can't until tomorrow.)

comment:4 Changed 11 years ago by marcusoverhagen

bug #1450 has been marked as a duplicate

comment:5 Changed 11 years ago by marcusoverhagen

bug #446 has been marked as a duplicate

comment:6 Changed 11 years ago by marcusoverhagen

bug #1309 has been marked as a duplicate

comment:7 Changed 11 years ago by marcusoverhagen

bug #1012 has been marked as a duplicate

comment:8 Changed 11 years ago by marcusoverhagen

Cc: jackburton stippi added
Component: - GeneralKits/Media Kit

I started debugging this issue in July 2007, but I was unable to find a correct solution at that time due to other work.

The problem is this:

Cortex seems to call SetTimeSource for each node during startup.

When no supported soundcard exists, as in VMware, it will call SetTimeSource on the system time source, giving the system time source as parameter.

At some later place it calls BTimeSource::SetRunMode on all nodes, which triggers an infinite loop of 0x204 (NODE_SET_RUN_MODE) messages.

I don't think the Cortex behaviour of changing run modes and time sources is correct. I believe it should not touch the configuration.

Until the root cause of this bug in the media kit is fixed, please do not modify Cortex.

I checked in some debugging instrumentation with hrev22029 which at least turnes the various lockups caused by this issue into a debugger call.

comment:9 Changed 11 years ago by jackburton

I think this has been fixed in hrev23867.

comment:10 Changed 11 years ago by marcusoverhagen

Resolution: fixed
Status: newclosed

This was fixed by Maurice Kalinowski in hrev23867.

Debugging instrumentation removed in hrev23900.

Note: See TracTickets for help on using tickets.