Opened 10 years ago

Closed 4 years ago

#7344 closed bug (not reproducible)

installer skips files when installing to a usb stick

Reported by: khallebal Owned by: korli
Priority: normal Milestone: R1
Component: Applications/Installer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All


to reproduce, create a partition on a stick as you would on a normal HD,then install to it using the installer, i got the same result using my boot setup or another image that i mounted first as source,the only missing files i noticed were "haiku_loader, kernel_x86 & runtime_loader.
can't tell precisely when this started,probably around : hrev40649 or a bit earlier,i didn't have time to narrow it down.

Change History (6)

comment:1 by khallebal, 10 years ago

this one seems to have been fixed,i didn't encounter this bug since rev:40894. i don't the right for closing bugs

Version 0, edited 10 years ago by khallebal (next)

comment:2 by stippi, 10 years ago

Before reading this ticket and specifically which files are affected, I have just now reviewed the Installer copy engine code. It is virtually impossible for the engine to skip files. At first I had thought it may be due to the multi-threaded copy process used by Installer, but the file, folder and symlink copies are all created in the same thread, the reading thread. Only the actual writing of file data happens in an extra thread, so if there is a bug in that code, the worst that can happen is that individual buffers are skipped, i.e. the target files are shorter and corrupt due to missing chunks. Since this has never been the case, I doubt there is any threading bug in the copy routine. Installer recursively iterates all source volume directories. It has a mechanism to skip certain files and folders, like the swap file (there is a separate ticket for skipping too much in /var). So the only other possible source for this problem could be in BDirectory's entry iteration or anywhere below that. Another possibility is that it was somehow impossible to open these files for reading, but Installer should have reported an error then and failed installing.

I don't really know what to do with this ticket, I don't like closing tickets like this without knowing what was/is going on.

comment:3 by khallebal, 10 years ago

i don't know how i can help to figure out what went wrong;but you can try one of the nightlies between rev:40605 & 40649,but you have to boot all the way to the desktop and perform the installation from there to reproduce this case,you won't get the same result if you boot only to the installer?it happened to me twice with 2 different nightlies that are between the 2 i mentioned above?i hope this helps a bit.

ps: i use the same stick i've been using for months.

comment:4 by diver, 10 years ago

I've recently run into a similar issue while trying to install Haiku from one virtual HD to another in VirtualBox.

I decided to install new revision on top of another. Installer didn't warn me that there was not enough space on the destination volume and started to copy files, but almost at the end of installation it told me that there was not enough space left. It was already late and I went to sleep and completely forgot that it hadn't finish installation. So today I tried to boot from this .vmdk image and end up with "haiku_loader not found" message.

I've tried to reinstall and noticed that Installer copies haiku_loader and friends at the very end of installation. Maybe it was something like that with this ticket too?

comment:5 by khallebal, 4 years ago

I haven't seen this behaviour since ages, i'm suspecting that it was the bug in Drivesetup which used to initialize drives incorrectly that made some packages were skipped, so i think it can safely be closed now.

comment:6 by pulkomandy, 4 years ago

Resolution: not reproducible
Status: newclosed

Thanks for reporting.

Note: See TracTickets for help on using tickets.