Opened 8 years ago

Closed 6 years ago

#7475 closed bug (duplicate)

ethernet ar81xx does not show in network prefs.

Reported by: bbjimmy Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/net_server Version: R1/Development
Keywords: Cc:
Blocked By: #6423 Blocking:
Has a Patch: no Platform: All

Description

hrev40467 gcc4 hybrid completely repeatable on my eeepc:

Connect to a wifi using atheroswifi.

change prefs for the atheroswifi to static to prevent losing connection when there are more than one wifi connection detected and re-boot to make the setting stick - otherwise the connection will lose its ip.

the atheros wifi connection is now stable, byt the ar81xx device has been removed from the network prefs.

to find the ar81xx ethernet:

renove /boot/common/settings/interfaces and re-boot.

Attachments (5)

syslog (272.5 KB) - added by bbjimmy 8 years ago.
syslog
interfaces (125 bytes) - added by bbjimmy 8 years ago.
/boot/common/settings/network/interfaces
resolv.conf (51 bytes) - added by bbjimmy 8 years ago.
resolv.conf
listdev.txt (2.4 KB) - added by bbjimmy 8 years ago.
output if listdev
syslog.2 (391.3 KB) - added by bbjimmy 7 years ago.
syslog 04-1`9-2012

Download all attachments as: .zip

Change History (15)

Changed 8 years ago by bbjimmy

Attachment: syslog added

syslog

Changed 8 years ago by bbjimmy

Attachment: interfaces added

/boot/common/settings/network/interfaces

Changed 8 years ago by bbjimmy

Attachment: resolv.conf added

resolv.conf

Changed 8 years ago by bbjimmy

Attachment: listdev.txt added

output if listdev

comment:1 Changed 8 years ago by bbjimmy

should be: remove boot/common/settings/network/interfaces

comment:2 Changed 8 years ago by phoudoin

Could you please if the issue is still there after hrev41274? Thanks.

comment:3 Changed 8 years ago by bbjimmy

The issue persists on hrev41279.

comment:4 Changed 7 years ago by diver

Does it still occur?

comment:5 Changed 7 years ago by diver

Component: Network & InternetServers/net_server
Owner: changed from nobody to axeld

comment:6 Changed 7 years ago by bbjimmy

The symptoms have changed.

Since I have not had trouble with dhcp for quite some time, I haven't tested.

Now, hrev44041, the atheroswifi is the network adapter that does not show after setting it to a static ip. The ar81xx is now shown as being set to the static ip. ??? I don't get it. Again, deleting boot/common/settings/interfaces and re-booting solves the issue.

comment:7 Changed 7 years ago by diver

Version: R1/alpha2R1/Development

Could you please try to set atheroswifi to static, reboot and attach your syslog right after boot?

Changed 7 years ago by bbjimmy

Attachment: syslog.2 added

syslog 04-1`9-2012

comment:8 Changed 7 years ago by bbjimmy

Disregard my remarks on the symptom changing,I must have set the ar81xx to static. I set the wifi to static and nor the ar81xx has been renoved from Network perferences again. attatched is the latest syslog.

comment:9 Changed 7 years ago by dsuden

The removable of the interfaces file and rebooting fixed it for me (I'm not the original poster here, but was happy to have the solution!)

comment:10 Changed 6 years ago by diver

Blocked By: 6423 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.