Opened 8 years ago

Closed 8 years ago

#7585 closed bug (duplicate)

[kernel] panics upon opening any unsupported file types or folders in mplayer

Reported by: diger Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #7502 Blocking:
Has a Patch: no Platform: x86

Description (last modified by siarzhuk)

Any recent revision of gcc4hybrid or gcc4 builds.

Kernel crashes after running mplayer, such as: ~> mplayer /boot/home/mail

mplayer

This bug not reproduced on virtual machines.

Attachments (1)

KDL.jpg (2.5 MB) - added by diger 8 years ago.

Change History (8)

Changed 8 years ago by diger

Attachment: KDL.jpg added

comment:1 Changed 8 years ago by siarzhuk

Description: modified (diff)
Summary: [kernel] panics upon opening any unsupported any unsupported file types or folders in mplayer[kernel] panics upon opening any unsupported file types or folders in mplayer

comment:2 Changed 8 years ago by scottmc

Can you define recently? The SDLLibs were just rebuilt in the past few days, so that may or may not have something to do with this. Where did you get your SDLLibs from? installoptionalpackage or Haikuware?

comment:3 Changed 8 years ago by diger

This version with native audio/video(from 3deyes), not used SDL. But with an SDL bug also reproduced

comment:4 in reply to:  3 ; Changed 8 years ago by scottmc

Replying to diger:

This version with native audio/video(from 3deyes), not used SDL. But with an SDL bug also reproduced

Ok. But what version of Haiku did this happen on? Any what was the last version of Haiku where it actually worked? That might help narrow down the cause.

comment:5 in reply to:  4 Changed 8 years ago by diger

Replying to scottmc:

Ok. But what version of Haiku did this happen on? Any what was the last version of Haiku where it actually worked? That might help narrow down the cause.

As far as I know - never. I do not know the Haiku version where mplayer worked fine. This bug was a year ago. It is strange that nobody noticed.

comment:6 Changed 8 years ago by diver

Shouldn't this ticket be fixed before alpha3 as mplayer one of the apps which people will try if MediaPlayer fails to open some file.

Last edited 8 years ago by diver (previous) (diff)

comment:7 Changed 8 years ago by bonefish

Blocked By: 7502 added
Resolution: duplicate
Status: newclosed

Closing as a duplicate of #7502.

Note: See TracTickets for help on using tickets.