Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7595 closed bug (fixed)

Can't start BootManager

Reported by: idefix Owned by: axeld
Priority: normal Milestone: R1/alpha3
Component: Applications/Installer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

Installer won't start BootManager when the mime-info database isn't updated.

Steps to reproduce:

  1. Download an R1 Alpha3 RC cd-image (eg. haiku-r1a3-rc-r41789-cd.tar.xz)
  2. Boot from the cd
  3. Choose Run Installer in ReadOnlyBootPrompt
  4. Select Tools - Set up boot menu
  5. You get a warning stating "Bootman, the application to configure the Haiku boot menu, could not be launched."

To fix this, the code in InstallerWindow.cpp should be changed to search for BootManager in the apps folder.

Also, the warning should read "BootManager, the application to configure the Haiku boot menu, could not be launched."

Attachments (1)

installer.patch (1.6 KB ) - added by idefix 8 years ago.
Fix launching of BootManager when mime database is incomplete

Download all attachments as: .zip

Change History (8)

comment:1 by idefix, 8 years ago

The attached patch should fix it. (Not tested yet.)

Version 0, edited 8 years ago by idefix (next)

by idefix, 8 years ago

Attachment: installer.patch added

Fix launching of BootManager when mime database is incomplete

comment:2 by idefix, 8 years ago

Has a Patch: set

comment:3 by mmadia, 8 years ago

Would updating the warning text from "Bootman" to "BootManager" partially break Installer's catalog files?

comment:4 by humdinger, 8 years ago

"Break" is too hard a word. It'll invalidate the string and add a new one that needs to be translated again. Which is more or less a copy&paste thing. As it looks like alpha3 is delayed a while longer, that's no problem whatsoever, I think.

comment:5 by axeld, 8 years ago

Owner: changed from korli to axeld
Status: newin-progress

comment:6 by axeld, 8 years ago

Milestone: R1R1/alpha3
Resolution: fixed
Status: in-progressclosed

Applied in hrev41837, thanks a lot!

comment:7 by mmadia, 8 years ago

Version: R1/alpha3R1/Development

R1 Alpha 3 has not yet been released. This was with an R1 Alpha 3 Release Candidate image.

Note: See TracTickets for help on using tickets.