Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#7625 closed bug (duplicate)

BSimpleSound -> loading mixer.media_addon failed

Reported by: cipri Owned by: jackburton
Priority: normal Milestone: R1
Component: Kits/Game Kit Version: R1/Development
Keywords: BSimpleSound Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

I'm trying to use the BSimpleSound class. I'm using hrev41759 and the oss drives (because the auchi driver doesnt work for me), that means i have sound using oss drivers.

My programm compiles but when i start it in terminal i see the message:

BMediaRoster::InstantiateDormantNode: addon-id 6, flavor_id 0, flags 0x0
resolve symbol "__tf11BTimeSource" returned: -2147478780
DormantNodeManager::LoadAddon: loading "/boot/system/add-ons/media/mixer.media_addon" failed: Symbol not found
DormantNodeManager::GetAddon: can't load add-on 6 from path /boot/system/add-ons/media/mixer.media_addon
BMediaRosterEx::InstantiateDormantNode: GetAddon failed

Change History (11)

comment:1 Changed 8 years ago by diver

Description: modified (diff)
Version: R1/alpha2R1/Development

comment:2 Changed 8 years ago by cipri

I mean of course BSimpleGameSound (BSimpleSound doesn't exist).

comment:3 Changed 8 years ago by mmlr

This sounds like a GCC mismatch between the application and the mixer. Is it possible that you're using a GCC4 app under a GCC2 Haiku or the other way around, respectively a GCC4 app under a GCC2 based hybrid or the other way around?

comment:4 Changed 8 years ago by cipri

I'm using hrev41759 which is r1a3-rc. I guess this means, it's a hybrid. I used setgcc gcc4 to switch to gcc4. That means, my program is compiled with gcc4 on r1a3-rc

comment:5 Changed 8 years ago by anevilyak

That's probably the issue then...media add-ons aren't currently built for both compilers since in most cases they're just instantiated in the media add-on server, so the apps aren't directly exposed to the ABI. Looks like BSimpleGameSound is an exception.

comment:6 Changed 8 years ago by cipri

Yes. It seems so. I did a little test-application... and compiling it with gcc2 and it worked. But for my game i really need gcc4.

Is there a hope to see this fixed before A3 is released?

Last edited 8 years ago by cipri (previous) (diff)

comment:7 Changed 8 years ago by cipri

I just found on the haiku-forum that more than a year ago somebody had exactly that problem, but didnt write a bug-report. I guess, it would be important to solve that bug before r1a3 is released

Version 0, edited 8 years ago by cipri (next)

comment:8 Changed 8 years ago by leavengood

I did a little research and the issue seems to lie in the utility class BGameSoundDevice, which instantiates it's own mixer. There is a comment from Marcus from #575 saying this was a bad idea, so it should be fixed:

http://dev.haiku-os.org/browser/haiku/trunk/src/kits/game/GameSoundDevice.cpp#L305

Doing that should allow a GCC4 compiled game to play sound using BSimpleGameSound on a GCC2 Haiku.

In general the game kit really needs some love I think.

comment:9 in reply to:  7 Changed 8 years ago by korli

Replying to cipri:

I guess, it would be important to solve that bug before r1a3 is released

I don't want to come as a blow, but this probably won't happen before.

comment:10 Changed 8 years ago by pulkomandy

Resolution: duplicate
Status: newclosed

Duplicate of #7351

comment:11 Changed 7 years ago by cipri

The duplicase #7351 was closed as fixed (i didnt check it), but on hrev43942 (gcc2h) it still doesnt work. I have now the errors:

resolve symbol "nothrow" returned: -2147478780
PluginManager: Error, load_add_on(): Symbol not found
PluginManager: Error, loading PlugIn ffmpeg failed
PluginManager::CreateReader: GetPlugin failed
resolve symbol "nothrow" returned: -2147478780
PluginManager: Error, load_add_on(): Symbol not found
PluginManager: Error, loading PlugIn ffmpeg failed
PluginManager::CreateReader: GetPlugin failed
resolve symbol "nothrow" returned: -2147478780
PluginManager: Error, load_add_on(): Symbol not found
PluginManager: Error, loading PlugIn ffmpeg failed
PluginManager::CreateReader: GetPlugin failed
resolve symbol "nothrow" returned: -2147478780
PluginManager: Error, load_add_on(): Symbol not found
PluginManager: Error, loading PlugIn ffmpeg failed
PluginManager::CreateReader: GetPlugin failed
resolve symbol "nothrow" returned: -2147478780
PluginManager: Error, load_add_on(): Symbol not found
PluginManager: Error, loading PlugIn ffmpeg failed
PluginManager::CreateReader: GetPlugin failed
resolve symbol "nothrow" returned: -2147478780
PluginManager: Error, load_add_on(): Symbol not found
PluginManager: Error, loading PlugIn ffmpeg failed
PluginManager::CreateReader: GetPlugin failed
Note: See TracTickets for help on using tickets.