Opened 8 years ago

Closed 5 months ago

#7869 closed bug (fixed)

PANIC in mmu_init()

Reported by: manveru Owned by: nobody
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/alpha3
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm trying the anyboot image on an USB stick on my "Fujitsu FMV-BIBLO MG/G75N".

The BIOS is "Phoenix BIOS 1.12", and the CPU is "Intel Core i7 CPU M 620 @ 2.67GHz", the machine has 4GB of RAM.

Soon after selecting to boot from the stick, I get following error message: "mmu_init(): Failed to add physical memory range 0x100000000 - 0x138000000"

Before that there is a glimpse of a magenta underscore that pauses sometimes if i hold shift, but continues to the panic as soon as I release shift.

I have tried with R1/alpha3 and hrev42471-x86gcc2hybrid-anyboot without any visible difference.

On IRC, aldeck suggested that it might be caused by "sandy bridge".

Thanks in advance.

Attachments (3)

lspci.txt (2.2 KB) - added by manveru 8 years ago.
proc_cpuinfo.txt (3.3 KB) - added by manveru 8 years ago.
Output of /proc/cpuinfo
dmesg.txt (55.4 KB) - added by manveru 8 years ago.
Output of dmesg

Download all attachments as: .zip

Change History (21)

Changed 8 years ago by manveru

Attachment: lspci.txt added

Changed 8 years ago by manveru

Attachment: proc_cpuinfo.txt added

Output of /proc/cpuinfo

Changed 8 years ago by manveru

Attachment: dmesg.txt added

Output of dmesg

comment:1 Changed 8 years ago by diver

Blocking: 7665 added
Platform: x86-64All

comment:2 Changed 8 years ago by Dilbert

Similar problem here.

I have two laptops. Haiku runs fine on My aging Acer Aspire. My other laptop is a super awesome Asus G73S with 64 bits i7 Sandy Bridge processor and 6 gb ram. Haiku does not load on this one.

The error message when booting from CD is:

*** PANIC ***
mmu_init(): Failed to add physical memory range 0xdf7e8000 - 0xdf7fd000

Press key to reboot.
Last edited 8 years ago by Dilbert (previous) (diff)

comment:3 Changed 8 years ago by jrabbit

Keywords: sandy bridge i7 added

comment:4 Changed 8 years ago by jrabbit

Keywords: sandy_bridge added; sandy bridge removed

comment:5 Changed 8 years ago by phoudoin

The BIOS reports 10 usable physical memory address ranges. Unfortunatly, Haiku supports only 8 currently, hence why mmu_init() failed.

I guess the solution should be to improve this limit, in headers/private/kernel/boot/platform/bios_ia32/platform_kernel_args.h :

#define MAX_PHYSICAL_MEMORY_RANGE 32
#define MAX_PHYSICAL_ALLOCATED_RANGE 32
#define MAX_VIRTUAL_ALLOCATED_RANGE 32

I did a quick search, and I think there is no bad side-effect to fear, but I'll prefer one kernel guru check this before applying such change. The bios_ia32 platform may not be the unique one needing such change, too.

Meanwhile, if someone could test this change and report, thanks in advance.

comment:6 Changed 8 years ago by axeld

The only consequence is that whenever you change the kernel args, you'll need to update the kernel and the boot loader. Otherwise, this change looks fine to me.

comment:7 in reply to:  6 Changed 8 years ago by phoudoin

Replying to axeld:

The only consequence is that whenever you change the kernel args, you'll need to update the kernel and the boot loader. Otherwise, this change looks fine to me.

No possible issue with kernel_args size being to big?

comment:8 Changed 8 years ago by axeld

I wouldn't expect any for quite some time, at least, but it's not that I would remember what's going on (it's just part of the bss in the boot loader, and a pointer is passed into the kernel where it is then copied into the kernel bss section) ;-)

comment:9 Changed 8 years ago by phoudoin

Done in hrev42715.

Thanks to test and report (rebuild and update both haiku_loader and kernel_x86 from source, or just wait next nightly build).

comment:10 Changed 8 years ago by taos

Just for your information, hrev42715 also solved the boot problems of a HP G5333de desktop computer (Intel Core i3-550, 6 GB DDR3) that before only booted to:

PANIC: get_boot_partitions failed!

Thanks!

comment:11 in reply to:  10 Changed 8 years ago by phoudoin

Replying to taos:

Just for your information, hrev42715 also solved the boot problems of a HP G5333de desktop computer (Intel Core i3-550, 6 GB DDR3) that before only booted to:

PANIC: get_boot_partitions failed!

Interesting. I guess I'll have to search every tickets we have about this panic and see if it can be related indeed.

Thanks!

You're welcome ;-) Thanks for reporting it.

comment:12 Changed 8 years ago by phoudoin

Dilbert, manveru, could you try the fix and report the result, so we could close or move on this ticket? Thanks.

comment:13 Changed 7 years ago by Dilbert2

Finally. I tried to recover my password several times, but I could not log in. This is a new account, because Dilbert could not log on.

OK. Booted the latest nightly. Got a error message. The screen is black, with the HAIKU logo and the seven grey icons that become more colorful when Haiku loads. All seems to be normal until a big white text box fills the top of the screen.

PANIC: did not find any boot partitions! Welcome to Kernel debugging Land... Thread 22 "main2" running on CPU5 stack trace for thread 22 "main2"

Kernel stack: 0x81f60000 to 0x81f64000

Then there's a few lines with frame, caller, <image>:function + offset

I don't know if all that text is worth the effort of typing it here. Tell me if you really need it.

Four of the grey icons have got color. The last 3 are still grey.

By the way: Everytime I try to boot, the error message changes slightly. This time, "main2" is running on CPU 0 instead of 5.

The laptop is a Asus G73s with Sandy Bridge i7 2GHz 4 cores and hyperthreading.

comment:14 Changed 7 years ago by Dilbert2

New info.

The error that I mentioned earlier was when booting from DVD. The Asus G73sw manages to perfectly boot Haiku Nightly from a USB memory stick.

The problem seems to be the booting Haiku from DVD on this computer. Memory stick worked great.

Last edited 7 years ago by Dilbert2 (previous) (diff)

comment:15 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:16 Changed 11 months ago by waddlesplash

Keywords: boot-failure added; sandy_bridge i7 removed

comment:17 Changed 11 months ago by waddlesplash

Blocking: 7665 removed

comment:18 Changed 5 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

OK, then this ticket is fixed. If the DVD issue persists (it was probably also fixed) please open a new ticket.

Note: See TracTickets for help on using tickets.