Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#8132 closed bug (fixed)

Graphics not working with Lenovo S10-3t / Intel Atom N550

Reported by: loziniak Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: i915 N10 S10-3t N550 intel atom graphics driver Cc:
Blocked By: Blocking: #9157
Has a Patch: no Platform: x86

Description

I use haiku-nightly-hrev43005-x86gcc2hybrid-anyboot and startup screen is displaying, all the icons light up and then only a top line of pixels light up at the top of the screen (photo attached). When I move touchpad, this line of pixels is changing, so I assume that system is responding, but there is something wrong with graphics.

I also attach output of "lspci" on Linux, where i915 driver is used.

Attachments (2)

lspci.s10-3t.txt (1.5 KB) - added by loziniak 8 years ago.
lspci on Linux
CIMG1663_.JPG (113.3 KB) - added by loziniak 8 years ago.
photo taken after the boot process

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by loziniak

Attachment: lspci.s10-3t.txt added

lspci on Linux

Changed 8 years ago by loziniak

Attachment: CIMG1663_.JPG added

photo taken after the boot process

comment:1 Changed 8 years ago by anevilyak

Possibly related to #8001.

comment:2 Changed 7 years ago by loziniak

The problem is still present in haiku-nightly-hrev44354-x86gcc2hybrid-anyboot image.

comment:3 Changed 7 years ago by diver

You can boot in safe mode and then rename intel_extreme to intel_extreme.disabled for now.

comment:4 in reply to:  3 Changed 7 years ago by loziniak

Replying to diver:

You can boot in safe mode and then rename intel_extreme to intel_extreme.disabled for now.

ok, thanks for a workaround :-) if I could be of any help with debugging/testing, please let me know.

comment:5 Changed 7 years ago by loziniak

issue still present in haiku alpha 4.1

Last edited 7 years ago by loziniak (previous) (diff)

comment:6 Changed 6 years ago by axeld

Resolution: fixed
Status: newclosed

Should be fixed with hrev45352.

comment:7 Changed 6 years ago by axeld

Blocking: 9157 added

(In #9157) Indeed, thanks for the hint!

Note: See TracTickets for help on using tickets.