Opened 13 years ago

Closed 11 years ago

#837 closed bug (fixed)

[app_server] crash in Desktop::Cursor()

Reported by: diver Owned by: stippi
Priority: blocker Milestone: R1/alpha1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On real hw, while plaing around with SoundPlay, dunno how to reproduce yet.

Segment violation

Desktop::Cursor() Desktop::SetCursor() ServerApp::SetCurrentCursor() WindowsLayer::MouseMoved() MouseFilter::Filter() EventDispatcher::_EventLoop() EventDispatcher::_eventLooper()

Change History (9)

comment:1 Changed 13 years ago by wkornewald

Milestone: R1
Version: R1 development

comment:2 Changed 13 years ago by axeld

Priority: normalblocker

comment:3 Changed 12 years ago by axeld

Milestone: R1R1/alpha

comment:4 Changed 11 years ago by nielx

This ticket is a little bit vague for a nomination as blocker of the alpha 1 release. Diver, can you try to find a consistent method for reproduction?

comment:5 Changed 11 years ago by diver

I didnt' sow this crash for year now. I think its fixed.

comment:6 Changed 11 years ago by axeld

It hasn't been fixed yet, the code is still problematic. It only shows rarely, though (I remember running into it about two month ago the last time). Maybe it would be okay to move it to R1 instead, I dunno.

comment:7 Changed 11 years ago by stippi

I didn't see it either for a _long_ time, but yesterday I got a crash in HWInterface::_DrawCursor(), which I believe is originating from the same problem. I should write a test app which constantly changes the cursor shape, I think this is what triggers it, together with something else in the cursor code.

comment:8 in reply to:  6 Changed 11 years ago by nielx

Owner: changed from axeld to stippi

Replying to axeld:

It hasn't been fixed yet, the code is still problematic. It only shows rarely, though (I remember running into it about two month ago the last time). Maybe it would be okay to move it to R1 instead, I dunno.

Let's keep it here until we are at a later stage in the alpha 1 process, and then reevaluate. Anyway, assigning to stippi because he should write a test app :-)

comment:9 Changed 11 years ago by stippi

Resolution: fixed
Status: newclosed

Hopefully fixed in hrev24741. The bug was/is very hard to reproduce, so I cannot verify that the problem I saw was the indeed cause. Please reopen if you encounter it again.

Note: See TracTickets for help on using tickets.