Opened 7 years ago

Last modified 3 years ago

#8779 assigned bug

ShowImage doesn't correctly handle very large JPEG

Reported by: jstressman Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When attempting to load a very large image, in this case the full size JPEG image from the link at the bottom of this page:  http://photojournal.jpl.nasa.gov/catalog/PIA15689 (not the link at the top, which is considerably smaller, even though it says full size at the top as well)

The image is 23096 x 7981 pixels, 13.15MB

ShowImage shows the left side of the image again where the right side should be.

Attachments (1)

showimage-wrapbug1.png (1.0 MB ) - added by jstressman 7 years ago.

Download all attachments as: .zip

Change History (6)

by jstressman, 7 years ago

Attachment: showimage-wrapbug1.png added

comment:1 by hometue, 7 years ago

(GCI-2012 Participant) Haiku revision: hrev44702. Still valid. The image used is the same as mentioned in the ticket. About 16315x7981 of the left side of the image is displayed correctly, but the rest of the area repeats the left side of the image. It is noticed that Album from haikuware.com can view the image correctly. System: Haiku R1-alpha4 on Virtualbox 4.1.20 on windows 7 64 bit

comment:2 by Janus, 6 years ago

The problem is in the application server (The scaling function uses 16bit offset). With 100% zoom the image is displayed properly.

Last edited 6 years ago by Janus (previous) (diff)

comment:3 by Janus, 5 years ago

The component of this ticket should be move to server/app_server. Thanks

comment:4 by humdinger, 5 years ago

Component: Applications/ShowImageServers/app_server
Owner: changed from leavengood to axeld

comment:5 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned
Note: See TracTickets for help on using tickets.