Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9106 closed bug (invalid)

Black screen with 3D Rage Pro AGP 1X/2X

Reported by: Morbid Owned by: gerald.zajac
Priority: normal Milestone: R1
Component: Drivers/Graphics/ati Version: R1/Development
Keywords: ATI 3d Rage pro Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Installation from Haiku just possible in Failsave-Mode. If i boot Haiku normal there's just a black screen. Tried some ATI-Drivers from Bebits with the same result. After copy ATI-Driver and ATI-Eccelerant from ZETA it works.

Attachments (7)

ZETA_listdev.txt (6.9 KB ) - added by Morbid 7 years ago.
listdev_Hiku_with_ZETAdrvATI.txt (1.3 KB ) - added by Morbid 7 years ago.
syslog.txt (53.6 KB ) - added by Morbid 7 years ago.
Listdev_ATI_Rage IIC.txt (1.3 KB ) - added by Morbid 7 years ago.
syslog_ATI_Rage IIC.txt (53.6 KB ) - added by Morbid 7 years ago.
Belinea_technical_spec1.jpg (233.1 KB ) - added by Morbid 7 years ago.
Belinea_technical_spec1.2.jpg (274.6 KB ) - added by Morbid 7 years ago.

Download all attachments as: .zip

Change History (26)

by Morbid, 7 years ago

Attachment: ZETA_listdev.txt added

by Morbid, 7 years ago

comment:1 by diver, 7 years ago

Component: Drivers/GraphicsDrivers/Graphics/radeon
Owner: changed from nobody to euan

by Morbid, 7 years ago

Attachment: syslog.txt added

comment:2 by Morbid, 7 years ago

Not sure if it works correct! After selecting an opened Window and moving around the screen, use of Memory jumps up and i saw some "Ghost Windows". This not appear under ZETA. Expecting Haiku uses Vesa-Mode with this driver.

comment:3 by Morbid, 7 years ago

Sorry! Use of CPU was meant!

in reply to:  3 comment:4 by diver, 7 years ago

Component: Drivers/Graphics/radeonDrivers/Graphics/ati
Owner: changed from euan to gerald.zajac

Replying to Morbid:

Sorry! Use of CPU was meant!

This is probably because of #2769.

vendor 1002: Advanced Micro Devices [AMD] nee ATI
device 4742: 3D Rage Pro AGP 1X/2X (Rage Pro Turbo AGP 2X)

ati driver should support this hardware http://cgit.haiku-os.org/haiku/tree/src/add-ons/kernel/drivers/graphics/ati/driver.cpp#n74

comment:5 by Morbid, 7 years ago

Changed Graphic device! Now an ATI Rage IIC build in! Also black screen on booting with Haiku-CD. Blurred screen on booting Haiku and Zeta-Driver via Hard Disk. Thanks diver!

Last edited 7 years ago by Morbid (previous) (diff)

by Morbid, 7 years ago

Attachment: Listdev_ATI_Rage IIC.txt added

by Morbid, 7 years ago

Attachment: syslog_ATI_Rage IIC.txt added

comment:6 by diver, 7 years ago

Are these syslogs obtained with ati driver from Zeta of Haiku?

comment:7 by Morbid, 7 years ago

The syslogs are made after installing Zeta-Driver under Haiku. Will try it again with a new installation of Haiku and ATI Rage IIC. Have also problems with this card under Zeta. Test with all Resolutions and frequencies shows a blurred screen. Do not now for now if Haiku's ATI driver will work.

comment:8 by gerald.zajac, 7 years ago

I have tested the following two ati video cards with haiku releases hrev44220 and hrev44660:

3D Rage Pro, chip ID: 0x4742 3D Rage IIC, chip ID: 0x475A

The video worked fine under both releases with either video card. I used the ati video driver that came with these releases, and did not alter the driver in any way.

After looking at the syslog's attached to this report, it appeared to me that Morbid must be using the Zeta ati video driver since I did not see any output from the ati driver/accelerant in the syslog's; and Morbid did confirm that with his comment above. Thus, since Haiku's ati video driver was not used, this bug report should be closed.

It should be noted that when using the above listed ati video cards with some computers, the screen will be blank when the boot screen is normally displayed. However, the video displays normally with these ati video cards when the boot screen finishes, and the normal Haiku display is started. It is my understanding that video drivers are not used when the boot screen is displayed.

comment:9 by Morbid, 7 years ago

Hmmm! All I can say is that on booting all Symbols where shown. After init of all Icons the screen turned to black. On finishing booting Haiku the screen stay's black. Motherboard MS-6330 from MSI with AMD Athlon 1,1 GHz, 768 MiB of Ram. Changed the Video-Card again and put in a ATI Radeon R100 QD (Radeon 7200). With this Card no Problems on booting Haiku, but as i wrote above, on selecting and moving a Window across the screen the CPU use increases and "Ghost Windows" where shown. What kind of Hardware did you use for testing Rage Pro and Rage IIC? Are there "Ghost Windows" with Rage Pro, too? Thanks for commitment guys!

comment:10 by gerald.zajac, 7 years ago

I tested with an Intel D815EEA2 motherboard with a 1.0 GHz Pentium III processor and 256 MB of RAM, and an MSI K7T Turbo2 motherboard with an Athlon XP 1.66 GHz processor and 512 MB of RAM. Both video cards were tested on both computers and worked fine with a 1280 x 1024 monitor. The fact that your screen goes blank after the boot screen, is probably because you are using a Zeta video driver which does not work with Haiku. Until you use the Haiku ati video driver, we are just wasting our time writing comments for this bug report.

comment:11 by Morbid, 7 years ago

No, No. You missunderstood. Test a new Installation with Haiku R1Alpha4 44660 with all three Graphic-Cards and the ATI-Driver witch is comming with Haiku.

  1. 3D Rage Pro: Haiku installation from CD in FailSave-Mode. Booting after Installation from HD brings black screen. Boot in FailSafe-Mode with 1024x768 24bit works
  2. 3D Rage IIC: mounted after 3D Rage Pro with the same Installation of Haiku and the ATI Driver of Haiku. Black screen after HD-Boot. Boot in FailSafe-Mode with 1024x768 24bit works.
  3. ATI Radeon R100 QD (Radeon 7200): works with ATI driver from Haiku, but use of CPU increases and "Ghost Windows" will shown. Boot without FailSafe-Mode in 1024x768 32bit
  4. Copying the Zeta driver was a "poverty" solution. Only to test 3D Rage Pro and 3D Rage IIC. Removed it and copying the Haiku-Driver back. Now ATI Radeon R100 is installed and solutions up to 1920x1200 are possible. Monitor is a Belinea Model 10 50 35 so i just set it to 1024x768 32bit.

And sorry for wasting your time! I also have other things to do as installing and removing Haiku or installing Graphic-Cards one after another. If there is no Problem i wouldn't write and waste my time -> Ok, Mr.?

comment:12 by gerald.zajac, 7 years ago

Are you sure that you are now using the Haiku ati video driver? If you are using the Haiku ati video driver and you look at the syslog, you should see several lines in the file that start with "ati:", and one of them will state the resolution and other info about the mode that is being set. If you see no lines that start with "ati:", you are not using the Haiku ati driver.

After doing some investigation, I found that the Fail-Safe video mode applies only to the boot screen. When the normal Haiku screen appears it seems to always be the resolution that was used before Haiku was shutdown or restarted. I had thought that the Fail-Safe mode was also to be used for the normal Haiku screen, but that is not the case. Consequently, since you have a 1920x1200 monitor, Haiku could be trying to set the resolution to 1920x1200 after the boot screen is finished. Since these ATI 3D Rage chips are rather old chips (about 15 years old), they might not be able to handle 1920x1200. When I wrote the ati driver, the largest resolution I tested them with was 1680x1050, and they worked okay at that resolution. Thus, you should try a monitor with a lower resolution, or set the video to a lower resolution before you shutdown after using the Radeon card.

Also, it should be noted that the Radeon chip is not handled by the Haiku ati driver. Haiku has Radeon and Radeon HD drivers for those chips. If you want to see which chips are supported by the ati driver, look at the source file: http://cgit.haiku-os.org/haiku/tree/src/add-ons/kernel/drivers/graphics/ati/driver.cpp Starting at line 73 there is a chip table which gives the chip ID and name of each chip handled by the ati driver.

comment:13 by Morbid, 7 years ago

You where right with your assumtion that ATI Radeon R100 do not use the ATI driver from Haiku. So i changed to ATI Rage Pro and checked the settings in the BIOS and playing around with:

  1. AGP Aparture Size 8 MB
  2. AGP-4x Mode enabled/disabled
  3. AGP Driving Control set to auto
  4. AGP Master 1WS write enabled/disabled
  5. AGP Master 1WS read enabled/disabled

Have also checked and changed the Settings of my Monitor. Now it's set in Haiku to 800x600 16bit at 75 Hz and the Haiku driver was used. After restarting the PC all Symbols are shown and than black screen again. Maybe it is a communication Problem between ATI- and VIA-Driver.

by Morbid, 7 years ago

Attachment: Belinea_technical_spec1.jpg added

by Morbid, 7 years ago

comment:14 by Morbid, 7 years ago

I expect this is a problem between Haiku ATI driver and Haiku ATI accelerant on this PC.

comment:15 by Morbid, 7 years ago

Ok Guys! Ticket can be closed! And you will kill me if i tell you what was the Problem!

comment:16 by umccullough, 7 years ago

Resolution: invalid
Status: newclosed

Probably a good idea to mention the cause, even if it was a stupid mistake on your part. That way if someone else makes the same mistake and finds this ticket, it will save everyone the hassle of dealing with it again ;)

comment:17 by Morbid, 7 years ago

It was a Problem of my Monitor! The VGA-Cable is fixed inside and there where 2 cold braze points! Had to soldering them and it works! Thanks again and sorry for the PANIC! Ticket can be closed!

comment:18 by diver, 7 years ago

I wounder why ati driver from Zeta worked then? Maybe it was vesa after all?

comment:19 by Morbid, 7 years ago

I wounder, too! I'm working on it aprox. 3 years and waiting for the next release of nightly build/alpha, cause under windows 95/98/XP, Beos and Zeta there was no Problem. So i replaced the driver of Haiku with Zeta's driver and it works. From that point in my Brain was it must be a driver issue. Also checking some Graphic-Cards just like Matrox, Nvidia and S3 without any problems. And yesterday as i take a look in the Handbook of my Monitor i saw the VGA-connector and the Pin's 13 and 14. Thought to my self: holy ...., please don't let it be a connecting problem. As i opened the Monitor i began to measure the VGA-Cable and there was nothing broken. Under commitment of my Live i than switch the Monitor on and started to shake the wires and there was it! Maybe the Monitor is sensible for junction resistors. This would explain the horizontal blur of the Rage IIC-Card under ZETA and HAIKU.

Version 1, edited 7 years ago by Morbid (previous) (next) (diff)
Note: See TracTickets for help on using tickets.