Opened 7 years ago

Closed 17 months ago

#9204 closed bug (invalid)

Asus EEE PC 901 Wi-Fi ralink2860 - invalid MAC address

Reported by: libran Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/ralink2860 Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hello, sorry for the automatic translation. On my netbook Asus EEE PC 901 set Haiku Release 1 Alpha 4.1 I had a problem with the connection Wi-Fi (Ralink RT2860).

Wireless connection says: "no wireles network found"

In the console, no networks:

 ifconfig / dev/net/ralink2860/0 scan

~> 

It has been observed that the MAC address of Haiku Release 1 Alpha 4.1(4.0) incorrectly identifies:

 Welcome to the Haiku shell.

~> Ifconfig / Dev/net/ralink2860/0
Hardware type: Ethernet, Address: 00:0 c: 43:30:52:88
inet addr:, Bcast:, Mask:
inet6 addr: fe80 :: 20c: 43ff: fe30: 5288, Bcast: ffff: ffff: ffff: ffff ::, Prefix Length: 64
MTU: 1500, Metric: 0, up broadcast configuring
Receive: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
Transmit: 2 packets, 4 errors, 614 bytes, 0 mcasts, 0 dropped
Collisions: 0 

I suggested to replace the driver ralink2860 version of Haiku Release 1 Alpha 3.

After replacement, AP became seen, but without names:

 Welcome to the Haiku shell.

 ~> Ifconfig / dev/net/ralink2860/0 scan
name address signal auth
18: b0: ee: ac: d1: 0c 9 -
18: b0: ee: ac: d2: 0c 8 -
ae: c5: a7: c2: 42:0 c 7 -
18: b0: ee: ac: d0: 0c 7 -
19: e1: 00:38: e0: 0c 7 -
19: e1: 00:38: e1: 0c 8 -
19: e1: 00:38: e2: 0c 7 -
c0: 49: da: f0: a5: 0d 38 -
1f: c6: 44:2 f: 42:0 c 8 -
e6: ba: 9e: 11: e0: 0c 5 -
19: cb: 8d: 72: dd: 0c 16 -
7d: 68:3 e: 10: dc: 0c 7 -
c0: 91:12: ad: bb: 0c 9 -
26:18: ec: ab: c4: 0c 7 -
18: b0: ee: cf: 40:0 c 8 -
18: b0: ee: cf: 41:0 c 6 -
18: b0: ee: cf: 42:0 c 7 -
60:00: e6: 08:98:0 c 9 -
19: e3: e3: 63:9 d: 0c 7 - 

When you try to connect to any AP without a name, a window pops up:

"Could not join wireless network: Invalid Argument"

Driver version of Haiku Release 1 Alpha 3 MAC address identifies the correct:

~> Ifconfig
/ Dev/net/ralink2860/0
Hardware type: Ethernet, Address: 00:22:43:00:1 a: 2f
inet addr:, Bcast:, Mask:
inet6 addr: fe80 :: 222:43 ff: fe00: 1a2f, Bcast: ffff: ffff: ffff: ffff ::, Prefix Length: 64
MTU: 1500, Metric: 0, up broadcast configuring
Receive: 104 packets, 0 errors, 14388 bytes, 0 mcasts, 0 dropped
Transmit: 4 packets, 0 errors, 1240 bytes, 0 mcasts, 0 dropped
Collisions: 0 

I made a post on this forum: http://www.haiku-os.org/community/forum/asus_eee_pc_901_wifi_ralink2860_haiku_release_1_alpha_41_invalid_mac_address

and I am helped.

Change History (9)

comment:1 by diver, 7 years ago

Component: - GeneralDrivers/Network/ralink2860

comment:2 by korli, 7 years ago

Could you please check with hrev45145 or newer?

in reply to:  2 ; comment:3 by libran, 7 years ago

Replying to korli:

Could you please check with hrev45145 or newer?

Please explain in detail how to test it?

in reply to:  3 comment:4 by korli, 7 years ago

Replying to libran:

Replying to korli:

Could you please check with hrev45145 or newer?

Please explain in detail how to test it?

Depends on how it's currently installed (partition, usb key...)

  • Download the nightly image
  • Mount the image
  • Replace the driver ralinkwifi located in /boot/system/add-ons/kernel/drivers/bin/ with the one from /yourImage/system/add-ons/kernel/drivers/bin/ralinkwifi
  • Reboot

comment:5 by libran, 7 years ago

I tried a version of the haiku-nightly-hrev45148-x86gcc2hybrid-anyboot

The result is:

Netbook Wi-Fi card can not connect to my access point, if set encryption (WEP or WPA-PSK)

Connected only in Open System.

Haiku A4.1 + driver ralink2860 by Diver, Wi-Fi card is connected OK to the WPA-PSK mode.

comment:6 by diver, 7 years ago

korli, maybe wpa_supplicant add-on should also be recompiled?

in reply to:  6 comment:7 by korli, 7 years ago

Replying to diver:

korli, maybe wpa_supplicant add-on should also be recompiled?

Possibly, though the compat layer headers haven't changed much. BTW there are newer versions of wpa_supplicant (1.0 et 2.0).

comment:8 by philcostin, 4 years ago

I can confirm that I have the same issue

RT2860 WiFi - Works (sort of) with open networks - but when I try to connect to my home network which is WPA2 / TKIP, the connection process takes a very long time, and when the interface finally reports that it is ready, it has a "link-local" 169.x.x.x address and I can't use it.

This is on an Asus EEEPC 901

Everything works well except USB3 and WiFi (when using Encryption)

There was a time when this worked OK - several years ago now. I guess the only way to know is to git-bisect but someone more qualified might be able to ascertain the problem faster than me since it would probably take me several weeks to get around to finishing that process!

Version 1, edited 4 years ago by philcostin (previous) (next) (diff)

comment:9 by waddlesplash, 17 months ago

Resolution: invalid
Status: newclosed

ralink2860 driver has been removed; its functionality is now provided by ralinkwifi.

Note: See TracTickets for help on using tickets.