Opened 6 years ago

Closed 6 years ago

#9653 closed enhancement (fixed)

Remove StyledEdit's character encoding display

Reported by: axeld Owned by: siarzhuk
Priority: normal Milestone: R1
Component: Applications/StyledEdit Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Besides the strange popup-lookalike triangle next to it, there is really no point for putting that kind of info there.

Haiku uses UTF-8 by default, and you only really care about the encoding if something is wrong. Looking into the menu is not too much to ask in this case.

Change History (3)

comment:1 by axeld, 6 years ago

Owner: changed from korli to siarzhuk
Status: newassigned

I think siarzhuk added this as part of a GCI, maybe he has a good argument for letting it in there? Or can explain what that triangle is about, at least.

in reply to:  1 comment:2 by siarzhuk, 6 years ago

Replying to axeld:

I think siarzhuk added this as part of a GCI, maybe he has a good argument for letting it in there? Or can explain what that triangle is about, at least.

This cell is about the opened file encoding. Unfortunately in russian-speaking countries we still have to deal with lot of files in cp1251, koi8-r and cp866 encoding. So we really need to have this information in sight and have possibility to switch the encoding on the fly - just to select correct encoding in case auto-detection had wrong assumption during opening the file.

From the other side, you are right, for most cases this info is superfluous - so this cell should be shown only in case non-UTF-8 encoding.

The "triangle" - is just an attempt to mark that there popup menu in this field. The menu idea comes from some of our users - just an attempt to simplify the encoding change but is, obviously, not perfect. ;-) IMO the shortcuts pair for iteration through list of encoding do the work more seamlessly. But the problem is to select good shortcuts for this.

comment:3 by siarzhuk, 6 years ago

Resolution: fixed
Status: assignedclosed

Behavior of encoding statusview cell improved in hrev45500. Default UTF-8 one is not shown anymore, popup encodings menu is removed, pair of shortcuts (Cmd-Opt-PgUp/PgDn) for quick iteration through the list was added. I hope it helps.

Note: See TracTickets for help on using tickets.