Opened 6 years ago

Closed 6 years ago

#9860 closed bug (fixed)

Deskbar crashes on restart if Workspaces were placed to Deskbar.

Reported by: Guest One Owned by: jscipione
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Workspaces, Deskbar Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I've experienced a crash of Deskbar after reboot. This crash happens only if Workspaces were placed to Deskbar. Removing /boot/home/config/settings/Deskbar_replicants helps to start Deskbar again. Crash report and relevant "Deskbar_replicants" are attached.

~> uname -a Haiku shredder 1 hrev45796 Jun 27 2013 00:36:12 BePC Haiku

Attachments (9)

Deskbar_replicants (282 bytes) - added by Guest One 6 years ago.
Deskbar-137-debug-11-07-2013-21-11-34.report (12.9 KB) - added by Guest One 6 years ago.
Workspaces_settings (308 bytes) - added by Guest One 6 years ago.
dbb-screenshot1.png (63.4 KB) - added by Guest One 6 years ago.
Reproducing bug. step 1
dbb-screenshot2.png (78.7 KB) - added by Guest One 6 years ago.
Reproducing bug. step 2
dbb-screenshot3.png (68.5 KB) - added by Guest One 6 years ago.
Reproducing bug. step 3
dbb-screenshot4.png (83.1 KB) - added by Guest One 6 years ago.
Reproducing bug. step 4
dbb-screenshot5.png (88.3 KB) - added by Guest One 6 years ago.
Reproducing bug. step 5
Deskbar-673-debug-15-07-2013-00-45-05.report (12.6 KB) - added by Guest One 6 years ago.
Reproducing bug. Crashlog.

Download all attachments as: .zip

Change History (16)

Changed 6 years ago by Guest One

Attachment: Deskbar_replicants added

Changed 6 years ago by Guest One

Changed 6 years ago by Guest One

Attachment: Workspaces_settings added

comment:1 Changed 6 years ago by Guest One

Summary: Deskbar cashes on restart if Workspaces were placed to Deskbar.Deskbar crashes on restart if Workspaces were placed to Deskbar.

comment:2 Changed 6 years ago by diver

Milestone: UnscheduledR1
Owner: changed from axeld to jscipione
Status: newassigned

comment:3 Changed 6 years ago by anevilyak

I can't reproduce this crash. Was this just an install from a nightly image or what?

comment:4 Changed 6 years ago by jscipione

I also cannot reproduce this crash, more information is needed. You must be in vertical mode judging from the debug report. Under what conditions might calling Window()->Frame() crash an application?

comment:5 Changed 6 years ago by anevilyak

Either an invalid (Deleted) window pointer, or the view isn't actually attached to the window at time of call, in which case Window() will return NULL.

Changed 6 years ago by Guest One

Attachment: dbb-screenshot1.png added

Reproducing bug. step 1

Changed 6 years ago by Guest One

Attachment: dbb-screenshot2.png added

Reproducing bug. step 2

Changed 6 years ago by Guest One

Attachment: dbb-screenshot3.png added

Reproducing bug. step 3

Changed 6 years ago by Guest One

Attachment: dbb-screenshot4.png added

Reproducing bug. step 4

Changed 6 years ago by Guest One

Attachment: dbb-screenshot5.png added

Reproducing bug. step 5

Changed 6 years ago by Guest One

Reproducing bug. Crashlog.

comment:6 Changed 6 years ago by Guest One

I successfully reproduced this bug on different hardware. These are screens of every sept to get the bug.

comment:7 Changed 6 years ago by jscipione

Resolution: fixed
Status: assignedclosed

With these quite detailed instructions I was able to reproduce the bug. Fixed in hrev45860.

Note: See TracTickets for help on using tickets.