Ticket #18508: shell.nix

File shell.nix, 401 bytes (added by dufresnep, 16 months ago)

working shell.nix (used by nix-shell before calling ./configure --cross-tools-source ../buildtools --build-cross-tools x86_64

Line 
1with import <nixpkgs> {}; {
2 qpidEnv = stdenvNoCC.mkDerivation {
3 name = "my-buildhaiku-environment";
4 hardeningDisable = [ "format" ];
5 buildInputs = [
6 gcc11 # version chosen without good reason
7 zlib
8 flex
9 bison
10 texinfo #makeinfo
11 autoconf #autoheader
12 automake
13 gawk
14 nasm
15 wget
16 zip
17 unzip
18 xorriso
19 mtools
20 zstd # for when running jam
21 bc
22 python3
23 ];
24 };
25}